Groups

    Big graphics card issue

    Have a HD4870 purchased end of 2008 but was just tested then and unused till August last year when my other one was damaged in a house move.

    It has been working great till I had to remove it to connect a cable to the IDE port at bottom of motherboard under the pci'e slot

    Since I put it back it it has a problem working, first one is that it wont turn on first time, or in other words pc gets power to all components but nothing appears on screen then you have to wait about 5 minutes then turn power off at mains or button on front then as soon as you press it again the pc works.

    Everything is working and the temperature is low but any games or emulators using D3D just crash and wont work even after a full reinstall of Windows, yet use the onboard graphics and they work.

    Any ideas to the fault?

    16 Comments

    Could be the slot, you tried another card in it?

    Original Poster

    Dont have another card to test, but took out my psu and graphics card and placed it into another pc with the same specs and had the same issue with power on i.e nothing at all for a few minutes then it worked but as had no installed games or emulators to test couldnt test them.

    I suppose there is a chance it could be the power supply.

    If it is the card though, I doubt there is much you can do to fix it, perhaps RMA it.

    Original Poster

    The PSU is under 6 months old so I doubt its that and its strange that the only thing that it has a problem with is the first power on instance and D3D/Direct3D in older stuff like Medal Of Honor Allied Assualt and Epsxe yet modern games and stuff like CS:Source and World Of Warcraft work without a single problem so.

    To be honest Ryouga, the only issues I have seen with Gcards are when they have been dead completely or they artifact like hell on any 3D game or in some cases even in 2D.

    So there is a good chance it may just be the PSU and that it isn't pumping enough power to the rear power slots on the card.

    What brand is the PSU?

    edit: Have you tried switching over the 6pin PCIe power plugs? If you have 4, 2 coupled to each cable, try 1 from each cable for example.
    Edited by: "PhearFactor" 18th Sep 2010

    Original Poster

    OCZ Stealthstream 600W Psu.

    I have even gone as far as minimize every setting in the emulator or game and still they wont even start.

    If its a Gcard issue then it does sound a strange one. Although I wouldn't like to say for definite that it is until you check the PSU. Like I said, most issues I get with Gcards are that they are dead or have serious artifacting issues.

    What else do you have in the system?

    In the PCI slots etc.
    Edited by: "PhearFactor" 18th Sep 2010

    Original Poster

    Thats what I thought since if more demanding and newer games like CS Source and WOW work without a hitch then why doesnt older ones.

    On the PS1 emulator if I change it to DirectX6 mode it works problem free its just on D3D mode when FMV's and game intros work but as soon as you start the game proper the music continues as does the game but the screen is frozen, this is on a windowed game or a full screen one.

    CS Source and WoW are very heavily CPU dependant games. Chances are they won't really be pushing the GPU that much. You need to try a game like Crysis preferably, or run a Benchmark from Futuremark.

    It could be a software issues, drivers etc. I am going to assume you have tried changing drivers though.

    Original Poster

    PhearFactor

    CS Source and WoW are very heavily CPU dependant games. Chances are they … CS Source and WoW are very heavily CPU dependant games. Chances are they won't really be pushing the GPU that much. You need to try a game like Crysis preferably, or run a Benchmark from Futuremark.It could be a software issues, drivers etc. I am going to assume you have tried changing drivers though.



    Still but a 8 or 9 year old game shouldnt be gpu intensive either!

    If it was software related then why did a clean format and reinstall of Windows give the same issues and this was with the latest drivers installed.

    I have got even newer drivers now so was going to reinstall and test, still that wouldnt describe the power on fault.

    No your right, that power on issue would not be caused by drivers. Although it could be a separate issue hehe.

    Do you have a standalone network card, sound card etc installed? Have you tried booting the system with no peripherals plugged in (mouse etc). Have you done a BIOS update recently or cleared the CMOS?

    Then in to the system issue, I would try running a benchmark and seeing what happens. If the Gcard has any serious issues, chances are you will find out by using 3D Vantage.

    edit: Forgot, you mentioned installing an ide cable (and drive I presume) and then these issues happening, have you tried unhooking the cable/drive, does the power on issue still happen?

    I suppose you could try the PSU on the other system without the Gcard and see if the power on issue happens. Then you would know if that issue is being caused by the PSU and not the Gcard.

    Edited by: "PhearFactor" 18th Sep 2010

    Original Poster

    Right just uninstalled driver and put in new one and the crashing issue is sorted at least as far as the emulator is concerned.

    Well as for the power on issue, I tried the psu and graphics card on a different pc and had the same power on issue so its either psu or graphics card.

    The Ide hard drive was only in to install a few ps2 games.

    EDIT strange though that originally after a pc format and reinstall and newer drivers than before the reinstall had the same issue now it is working weird.
    Edited by: "ryouga" 18th Sep 2010

    Yeah sorry, slighty tipsy lol. Like I put in my edit, err, try the PSU in the other system without the Gcard, you need to find out if it is the PSU or the Gcard. Don't take anything else with you, just the PSU.

    Original Poster

    Lol well I know on this pc because it has onboard it works first time without graphics card, the second you press the button or power at the mains the pc posts straight away.

    Of course, but that doesn't mean the PSU isn't having an issue with your card all on it's own. I mean it is using a lot of power, there is still a chance the PSU could be having issues. You said you have a similar spec machine, does it have a similar Gcard that requires extra power connectors at the back?

    Basically, the only way to test the PSU is by making sure its using a similar sort of power or higher to what it is using now.

    I am guessing this is running on W7 Have you tried running the Gcard on a older driver?
    Post a comment
    Avatar
    @
      Text
      Top Discussions
      1. How dangerous is Donald trump?31137
      2. ❅☁☁❅ I want☼to talk☼about the☔WEATHER☔no politics☃no religion❅☁☁❅18846166
      3. Just heard this...2 ★★★★★★★★★★★★★★ congrats to all on 392k ★★★★★★★★★★★★★★7764206
      4. Microsoft Gamescom - Possibly more free games / Project Scorpio44

      See more discussions