Groups

    Bloody memory of eBuyer!

    Hi people

    Bought some memory of ebuyer which was the exact one I needed for my PC. However when I tried to install it for the first time today it fits in the socket well however the clips which hold it in place do not properly click in!
    but the clips fit in well for the memopry stick which was already installed in my PC (OEM)
    Why is this?

    So I thought its a bit dangerous to leave it in the slot but not with the clips in?

    Please help lol

    6 Comments

    Sure its not DDR1 and your motherboard supports DDR2 which is smaller sized ram.

    Original Poster

    Yup am sure its the same one...used crucial memory scan...just that this memory stick is the same length 168 pin but dunno why its jus slightly wider thus clips do not fit properly.

    When I upgraded mine lately I had to be quite forceful in pushing the memory all the way in. Are you sure you are pushing it in hard enough, when you do so the clips close automaically.

    Good luck.

    Original Poster

    I tried once again put a bit of pressure, and yup it went in lol think was being a bit too gentle bcuz was worried that if I break something lol

    Well first I put it in then my pc switched on but it wasnt being recognised then I opened PC back up again and just swapped the side with the sticker facing in to facing out then the PC wouldnt just switch on..lol..but now its taken back out and PC is up and working lol

    Any ideas?

    Original Poster

    Bump please help lol

    ITs happend to me before, I ended up taking the other stick out, and using it in another pc. I think that memory slots had it, and the motherboard is only a few month old.
    Post a comment
    Avatar
    @
      Text
      Top Discussions
      1. Do you use a case on your iPhone?1414
      2. Customs charged too much for a little item!66
      3. Xiaomi redmi note 4 firmware34
      4. Multi fuel stove deals11

      See more discussions