Can someone shed some light on a Windows 7 Caching issue?

9 replies
Found 4th Mar 2010
Hey all, running a nice new Sony Vaio with the core i3 processor in it, Windows 7 64 Bit and 4 GB Ram, anyhoo . . .

I have been copying all of my files over to it, and while it was doing so, it got very very slow. Now my old lappy doesnt do this, you can do whatever you want with it when you are copying files. I have checked the task manager, and there doesnt seem to be much going on, other than being 0MB of free memory. About 2GB of it is being used, and the other 2GB is being cached, but I think the caching is slowing it down because when I am copying these files, the memory seems to be running out.

Now, my theory is, 4GB is not enough memory!! Can this be true! ? ?!?

9 Comments

Banned

its the old vista copy bug that is copied into win7

Does it tell you how much is Available? You should have Total/Cached/Available/Free.

Original Poster

PhearFactor;8020688

Does it tell you how much is Available? You should have … Does it tell you how much is Available? You should have Total/Cached/Available/Free.



Yer. Total is 4000 ish
cached is 2000 ish
available is 2000 ish
free is 0

it only slows down when the memory is like this. For example when defragging and surfing. Or copying my pics over and surfing.

Well if available has 2000, then that is available. Although Free is 0, the way it works is that the memory is only cached until Windows needs it, then it can switch from Cached to being used, in milliseconds. So the slow down is not being caused by the memory usage.

Do you have the specification of your old laptops processor and the new one? Also the hard drive spec? These are probably more likely to be the culprit of the speed difference. Not enough cache on the Processor or perhaps the new laptop is using a 5400RPM hard drive whereas the old one was 7200RPM. Only guessing here, but the memory shouldn't be causing any problem.

I only have 2GB on this machine (Win7) and it reads as 90 Free, 1152 Available and 1116 Cached and I have never noticed any slow downs whatsoever. Basically you should look at the Free bit saying 0 as a good thing rather than a bad thing as it means Windows 7 features are utilizing all the available memory on things like Pre-Fetch etc, caching and what not. When the memory is needed, like I said before, it switches from being cached to being free, then to being used in so little time you should not actually notice any sort of stuttering or slow down or anything.

Turn off remote differential compression...even with an i7 920 and 6gig tri channel ddr3 my system slows down to a crawl when moving large files about (im talking 12gig files though) with RDC on

PhearFactor;8021134

Well if available has 2000, then that is available. Although Free is 0, … Well if available has 2000, then that is available. Although Free is 0, the way it works is that the memory is only cached until Windows needs it, then it can switch from Cached to being used, in milliseconds. So the slow down is not being caused by the memory usage. Do you have the specification of your old laptops processor and the new one? Also the hard drive spec? These are probably more likely to be the culprit of the speed difference. Not enough cache on the Processor or perhaps the new laptop is using a 5400RPM hard drive whereas the old one was 7200RPM. Only guessing here, but the memory shouldn't be causing any problem.I only have 2GB on this machine (Win7) and it reads as 90 Free, 1152 Available and 1116 Cached and I have never noticed any slow downs whatsoever. Basically you should look at the Free bit saying 0 as a good thing rather than a bad thing as it means Windows 7 features are utilizing all the available memory on things like Pre-Fetch etc, caching and what not. When the memory is needed, like I said before, it switches from being cached to being free, then to being used in so little time you should not actually notice any sort of stuttering or slow down or anything.



Sounds about right, mine at the moment stand at:
Total: 8191
Cahced: 5416
Available: 5480
Free: 125
Thus showing it has nothing to do with the 'Free' as with 8GB of ram and next to nothing open i hope i havent got just 125mb of ram left to use! :thumbsup:

Banned

works fine on my 4gb w7x64 system

copied 50gb to my ext.hdd and didnt go 'slow' at all.

define 'slow' as I could run a test copy and time it

Original Poster

Hey all, thanks for the replies. I am on it now, copying about 30 GB of photos over to the computer.

Its even struggling when I am typing this, the text is taking a while to come up!!! lol. I know its not the computer because the other one I had with the same processor did the same thing.

My old computer had the P8600 processor, this one has the new Core i3 Processor, can it be that much slower? Very weird.

The hard drives are both the same RPM, so I dont think the HDD is the issue.

Original Poster

After going through it all, I can see that the processor and hard drive are maxing out, by clicking the resource monitor thing, the hard drive and processor are maxing out!! Doh!! - Im gonna run a test on the other laptop and see if the same thing is happening. It may be me being paranoid.
Post a comment
Avatar
@
    Text
    Top Discussions
    1. I want to talk about the WEATHER no politics no religion19247656
    2. The ultimate Sunday roast only £5.46 for 4 people at ASDA21128
    3. Just heard this...2 ★★★★★★★★★★★★★★ congrats to all on 392k ★★★★★★★★★★★★★★7769544
    4. Exploding Paw Patrol foam soap Leaves child in ICU11

    See more discussions