Car electrics fault

18
Found 19th JulEdited by:"mart321"
Hi all, the mrs clio 2009, hazard lights started turning on intermittently. Thought it could be a low battery problem as our 2 year old was playing in the car with the lights. Charged the battery and its still happening. Hazard lights seem to come on every 20 seconds or so. I then have to press the hazard button after a few seconds and they go back off
I have tried pulling off the front unit and found the hazard connection which has a few different wires coming out of the back in a white plastic unit. Any idea how to prise this open without damaging it.

The front lights will now not turn off when the engine is started so im not sure if ive pulled a wire out when removing the frontage. There does appear to be some loose cables.. Heres some pics
2990767.jpgthese two pink ended cables are just loose.
2990767.jpgthis is the white plastic end from the hazard. Unsure how to remove cables
2990767.jpgthis wire is also loose.
Can anyone help. Hoping its something simple. I. Should probably add, the car has a foisty smell coming in through the air vents. It was bad the other week, we live in a tree lined street and loads of leaves etc had built into a sludge under the bonnet. I cleaned them off with a pressure washer. Hope I havnt somehow blasted the electrics.
Community Updates
AskHome & Garden
18 Comments
Do the hazard lights still come on with the button disconnected?

If not, I expect that it's making contact at the button end, maybe dirty inside.

The loose wires just look like unused connections for your stereo
Edited by: "Jace_Phoenix" 19th Jul
Jace_Phoenix14 m ago

Do the hazard lights still come on with the button disconnected?If not, I …Do the hazard lights still come on with the button disconnected?If not, I expect that it's making contact at the button end, maybe dirty inside.The loose wires just look like unused connections for your stereo


Yes, its still happening when the button is disconnected.
Might be a UCH fault then
Jace_Phoenix6 m ago

Might be a UCH fault then


Eurgh, yea. Bloody hope not like!
French cars are known for bad wiring. I am lucky I survived a Renault bursting into flames for no reason with only a skin graft after 3rd degree burns due to being parked about 500yds from a fire station and hospital. Get it checked out properly.
I had a clio and the electrics went all over the place when it was about four years old. I got rid in the end. Loved the car but hated the faults.
Photos 1 and 3 are the radio wiring and completely normal for them to be like that, photo 2 is the plug that goes into the back of the switch also looks normal if all the wires are secure. Definitely sounds like an earth fault.
cliosport657 h, 29 m ago

Photos 1 and 3 are the radio wiring and completely normal for them to be …Photos 1 and 3 are the radio wiring and completely normal for them to be like that, photo 2 is the plug that goes into the back of the switch also looks normal if all the wires are secure. Definitely sounds like an earth fault.


Ok thanks for that. Any idea how to check for am earth fault. Was thinking a possible UCH fault which could be expensive.
psychobitchfromhell10 h, 17 m ago

I had a clio and the electrics went all over the place when it was about …I had a clio and the electrics went all over the place when it was about four years old. I got rid in the end. Loved the car but hated the faults.


Mine too, I used to indicate and the hazards would then come on. Changed everything but the main controller and still faulty so I got rid
mart3212 h, 12 m ago

Ok thanks for that. Any idea how to check for am earth fault. Was thinking …Ok thanks for that. Any idea how to check for am earth fault. Was thinking a possible UCH fault which could be expensive.



Give BBA Reman a call and explain what’s going on. They deal in these issues and are pretty good. Cost me £150 instead of the 500 main dealers wanted
Dannyrobbo1 h, 21 m ago

Give BBA Reman a call and explain what’s going on. They deal in these i …Give BBA Reman a call and explain what’s going on. They deal in these issues and are pretty good. Cost me £150 instead of the 500 main dealers wanted


These were mentioned on the Renault forums. But a quick google search reveals terrible reviews so unsure about it.. Im going to have a play tonight and see what happens.
Anyone know how to get access to the UCH board, as it appears some soldering could sort this issue out.
I can help with the smell in the air vents:

carparts4less.co.uk/cp4…BwE


There is a code on voucher section for extra 15% off
Had bad issues with French cars and electrics! Open up the ECU check for corrosion! And as above wiring!
Found a guide about clearing the skuttle drain holes. Apparently these block up and water finds its way in.. Im pretty certain this has happened i had to clear loads of crap out the other week but knew nothing of these drain holes.. Im going to follow the guide and clean them out and then check for any water leakage and possibly replace a fuse and spray a bottle of wd40 all over the place, wd40 allways helps!
Yeah we had to use electrical contact spray- we done this several times mainly to get home on to the next garage they never did fix the original problem in the end it was too late. We found out the coolant was seeping ever so slightly over time and trickling UP threw the wiring looms which are wrapped in tape, and into the ECU terminal.
Right update on the problem. The scuttle drains on the car were completely blocked with mud and leaves There was standing water on both sides overflowing.. It was stagnant water aswell and stunk. I spent 3 hours last night taking off covers etc to get access and completely cleaned and unblocked them. I allowed everything to dry and give it a good wd40 ing then put it all back together.
The car was working fine last night with no hazard light issues.

Checked again this morning and when i unlock the car the hazards start going off and won't stop till I lock it again.
Obviously the water has got in somewhere. Im going to check under the footwells for damp tonight then try and locate the fuse for the hazard.
Just an update on this, might help someone in the future. Because the skuttle drains were blocked water was getting into the car. I lifted the carpets and there was a foam and rubber mat which was soaked through. After lifting these it was metal underneath and a couple of inches of water. Some electric cables were fully submerged.. I spent this week completing drying everything out. That sorted the problem out. Its now all back together and working fine. I will just have to inspect the skuttle drains Regularly, as if these block then water will get in very quickly.
Edited by: "mart321" 29th Jul
Post a comment
Avatar
@
    Text

    Top Discussions

    Top Discussions

    Top Merchants