Expired

Doctor who sonic screwdriver wii remote problems

9
Found 20th Jun 2012
I'm having problems charging a doctor who wii remote to the wii and wondered if anyone who has one can help ?
The first one had a solid red light ( as if it was charging ) but never charged and wouldnt synch at all (nothing happened when I pressed the synch button). I tried it in the wii and a usb plug for several hours to no avail.
I returned this one and received another . On the second one the red light flashes and I can manage to synch it to the wii (and then the red light charging light stays on ) but every five minutes it goes off and the red light flashes and I have to press one of the buttons to get the solid red light again.
I'm assuming that the red light has to be on to indicate charging but I cant keep pressing the remote every five minutes.
Perhaps someone who has one can shed light on what I am possibly doing wrong. I've tried googling but it seems to have such good reviews that I'm sure it must be me :-)
Community Updates
9 Comments
Banned
Totally miss read that title
sherg

Totally miss read that title



Mistyped your reply as well.
Original Poster
fanpages

Are you actively using the "Wiimote" in that five minute period, or is it … Are you actively using the "Wiimote" in that five minute period, or is it left without any use at all?



Not using it .
Original Poster
I have other official wii remotes too.
On the instructions for the Doctor Who remote it says that a solid red light indicates charging so when the controller goes to sleep the red light flashes (which I am assuming means it's not charging) but I may be wrong.
I would have thought that I could charge it first and synch it when it is charged but it appears not to be the case as the red light does not stay on unless it is synched and the controller is on with the blue light showing.
Thanks for your replies. Sorry if I'm not explaining it very well
I have bought 2 of these. One worked the other didn't. Synced it to the Wii then tried charging it but just constantly flashes and doesn't charge. My replacement is doing this too. At my wits end as to what is wrong with it. Looking at returning this one too unless there are any replies to tell me how to fix this.
Original Poster
I never did find a fix for mine. After second replacement I gave up. Shame though as the kids would have loved it.
I suspect its faulty wiring or something.
My remote experience the same problem. I opened it. The lithium battery look like 'exploded'. It's more a balloon than a battery. I will try to change it and then I'll let you know. To open the remote you just need to remove 6 screws (using a screwdriver, a normal one, not a sonic one ) and then carefully separate the two shells.
Edited by: "alberto1" 19th May 2013
I have just purchased 3 of these Wii controls all having the same issue as described here. After some intense investigation, I found the rechargeable lithium-ion batteries had discharged beyond minimal charge capacity as a result of age of stock.

The easiest solution would be to pull the battery out of the control and using a specially designed charger/power supply, put about 2 minutes worth of charge at 4.5-5.0v (any higher voltage and/or longer charging than this will cause permanent damage to the battery). After putting the initial charge into the battery, reassemble the control and follow the instructions that came with the 11th Doctor Who Sonic Screwdriver Wii control.

Hope this helps.
Original Poster
Thanks. I might have a go at this. Nothing to lose as they dont work anyway but I'm not sure if I have a suitable charger.
Post a comment
Avatar
@
    Text

    Top Discussions

    Top Discussions

    Top Merchants