External Drive - Showing no files

6 replies
Found 23rd Apr 2009
My sisters external drive is showing 'folder is empty' but drive properties say it has 197Gb used of the 931GB Capacity. She had probs with it last week - lots of files and folders created in root with naming being a letter of alphabet, and got an error when trying to move or delete any data on it. I ran a recovery or chkdsk and repair on it and seemed to sort it although there was still a file i which we could do nothing with.

Any ideas on what to do with it - her laptop is running Vista Home basic 32 bit, SP1 and when I looked up error on web last week it seemed to be a common Vista prob showing up with anything from drives to cd'sdvd's...

error then was 0x80070570: The file or directory is corrupted and Unreadable.....and still get that when I just tried to create a folder on that drive...could it be a firmware issue with drive, or is it maybe Vista related? Its a Buffalo drive -HD-CE1.OTU2-EU is info on bottom of drive....

Just trying to fix it for her before she takes me home tomorrow lunchtime!

Ta as always!

Nikki

6 Comments

Have you shown hidden files and folders?

I would take everything you want/need off the drive and format it.

Original Poster

Cant see anything on drive but did a search and downloaded new firmware for it that was released in Jan 2009. Implies its similar prob to one Seagate were having so perhaps seagate drives inside?? Anyway will run a chkdisk tonight and see how that goes! Fingers crossed thats what it is!

So theres nothing left on the drive you want???
Why not just format it??

Original Poster

Cos it says on properties that there is 197GB used and last time it didnt show some items a chkdsk brought stuff back will try running it and if get stuff back then great - can copy to dvd then reformat...

Nikki

I once had a similar problem with the disk not being accessible with too many files (over 500) in the root directory, that was with windows 2000 but vista may suffer from the same problem.

Unfortunately I just ended up formatting the partition in question since it didn't have anything important on it, I'm not sure how you'd go about recovering from it? Try a Linux LiveCD maybe and see if that sees the files?

Original Poster

Didnt manage to recover any data so have just formatted and checked that new firmware from january is on the drive. Fingers crossed thats it sorted now! Anyone else had problems since they put new firmware on?Any tips?
Post a comment
Avatar
@
    Text
    Top Discussions
    1. Krack WiFi vuln1121
    2. UBER can be a waste of money1019
    3. Sony announce £35,000 PlayStation Pro bundle...1216
    4. *****Free Ultraviolet Movie Codes*****28161

    See more discussions