Groups

    External HDD help

    I bough this item off ebay

    220143144848

    It should be plug and play for XP,but it cant see anything on my computer.
    It detects the HDD and i get the speech bubble thing on my windows bar,
    saying that "drivers installed ,your device is ready to use".
    I've rebooted my comp and i still cant see anything

    can anyone help

    19 Comments

    you need to open it up. Change the jumper (which is probably set to cable select) to master. On An external HDD, should already be set. Unless it's a media player aswell? Hope that helps

    Is it not showing when you:
    right click my computer
    manage
    disk management

    It should be there, sorry that is stating the obvious

    Original Poster

    boydent999

    Is it not showing when you:right click my computermanagedisk managementIt … Is it not showing when you:right click my computermanagedisk managementIt should be there, sorry that is stating the obvious



    tried that not there

    Original Poster

    ayaz

    you need to open it up. Change the jumper (which is probably set to cable … you need to open it up. Change the jumper (which is probably set to cable select) to master. On An external HDD, should already be set. Unless it's a media player aswell? Hope that helps



    according to the jumper its set to device0

    That's really odd, cos it's clearly not a cable issue cos of XP doing the initial recognition. Is there another pc you could try it on, another cable too?

    boydent999

    That's really odd, cos it's clearly not a cable issue cos of XP doing the … That's really odd, cos it's clearly not a cable issue cos of XP doing the initial recognition. Is there another pc you could try it on, another cable too?



    It could be. I have had that problem before, when a company makes an external HDD the jumpers are set to master. when somebody makes one from parts the HDD arrives as a cable select. Xp recognises but cannot see it as it is a USB connection. If you had a internal drive that would be set to slave as it is a seperate drive using IDE. But an external drive is a seperate drive so it has to be set as master. If That makes sense.

    I actually build media drives for a living and this is a common factor.

    Original Poster

    boydent999

    That's really odd, cos it's clearly not a cable issue cos of XP doing the … That's really odd, cos it's clearly not a cable issue cos of XP doing the initial recognition. Is there another pc you could try it on, another cable too?



    unfortunately i do have a cable but its in the attic,and i don't want to go fiddling around up there at this time.

    I can try it on my bros comp but he wont be home till Sunday

    Original Poster

    ayaz

    It could be. I have had that problem before, when a company makes an … It could be. I have had that problem before, when a company makes an external HDD the jumpers are set to master. when somebody makes one from parts the HDD arrives as a cable select. Xp recognises but cannot see it as it is a USB connection. If you had a internal drive that would be set to slave as it is a seperate drive using IDE. But an external drive is a seperate drive so it has to be set as master. If That makes sense.



    i don't ideally want to mess about with he external HDD incase i have to send it back.

    true, but its not as difficult as you think. Have you tried the drivers it comes with? The quicker thing to do would be to find a guy with a little know how. But just send it back I guess. As i said before if it's a normal External HDD, it should be recognised straight away & showup. Worst case, it's a dead HDD. The actual HDD enclosure is working because it shows up. Basially it 's 2 different things, The enclosure is alive & HDD it'self is inactive.

    Original Poster

    For some reason the drivers on the disc they sent are for Windows 98, It says xp doesn't need drivers

    last thing i can say is find the model number, go to the philips website & search for a driver. Can't really think of anything else. Sorry dude

    Original Poster

    ayaz

    last thing i can say is find the model number, go to the philips website … last thing i can say is find the model number, go to the philips website & search for a driver. Can't really think of anything else. Sorry dude



    Looked for that, couldn't find much.


    Cheers for the help guys,repped both of you

    Damn, was hoping between us we'd have it working :-(
    Nothing to lose waiting til the weekend and trying on your brother's mind, then if that fails, contact seller and tell him it's DOA
    Good luck

    You don't need drivers for XP, plus, it installed the controller anyway, the problem is recognising the drive.

    If you find going to Disk Management does not kick in an 'Initialize Disk' feature (which would happen if the drive is not partitioned/formatted), then it may be down to the drive inside or connections.

    As others have said, make sure the jumper is set to Master, most External Cases require it to be set to Master. It should be a simple case of taking a couple of screws out and revealing the drive, then it's just a power cable and an IDE connection (maybe some screws holding in the drive).

    EDIT: Just looked at the item, as it is a 2.5" Drive, it doesn't usually have jumpers set up anyways, so if Disk Management does not work when trying to Partition/Format, just contact the seller and advise it is DOA.

    Original Poster

    msged the seller he just says


    hi there,

    Can you pls format it on your pc again, for more details, pls have a look this webpage:

    hsuuk.sslpowered.com/hsu…pdf

    Regards,

    HSUUK

    I've told him i've tried this and i cant get past step 3.and he just sends the link again

    That's fundamentally what i suggested you do, so so much for the seller being helpful.
    I'd try it on your brother's pc, then tell the seller you've done that.
    If they keep sending the same link, contact ebay is my best bet and/or paypal

    Original Poster

    Just to update.
    I tried it on my bros laptop and it worked fine,so he formated it .

    It now works on my computer if i plug it into the USB in the back of my PC.

    If i plug it into my 4 in 1 USB sockets or in the front of my PC it fails to work

    Did you try plugging it into the USB ports on the back of your PC before? If it's USB Powered it may not have been getting enough power through the USB Hub?

    Excellent news really pleased it's now working
    I've got an external drive and no matter which usb slot i use it in, it won't work, so i've sent off for a mini y usb cable; it has two usb male ends and uses two usb ports, one for data transfer one for power so waiting for that but pleased your's is sorted now
    Post a comment
    Avatar
    @
      Text
      Top Discussions
      1. Just heard this...2 ★★★★★★★★★★★★★★ congrats to all on 392k ★★★★★★★★★★★★★★7764264
      2. ❅☁☁❅ I want☼to talk☼about the☔WEATHER☔no politics☃no religion❅☁☁❅18846184
      3. How dangerous is Donald trump?31147
      4. Microsoft Gamescom - Possibly more free games / Project Scorpio913

      See more discussions