Floureon CCTV and Sannce CCTV camera compatability

11
Found 5th Aug 2015
OK,

Last week I bought this FLOUREON DVR 8 Channel HDMI H.264 1080 Full HD 960H CCTV System on eBay

ebay.co.uk/itm…002

At the same time I bought a SANNCE Superior Resolution 900TVL/960H Home Security Camera System from Amazon.

amazon.co.uk/gp/…s00

I plugged in the DVR unit (installed a western digital hard drive) to the TV today and all well and good, shows the On Screen Menu, options etc. The disk drive is showing etc so all well and good. I then tried to connect the camera using the BNC connectors but nothing comes up on the screen, Camera 1 was just black, the other 7 channels were also the same. I made sure the camera had power going to it and the infa-red LEDS lit up so the power was there but nothing on the screen. I then tried an old Swann 510 camera and nothing. I tried pluging them into different camera inputs on the back but no joy, no image just the black screen.

The DVR did make a loud beep and the recording blue light came on, I can go to playback in the options and it shows that it has recorded to the hard drive but nothing, just black. I assume that it must be set to auto record when it powers on.

Ideas?
Community Updates
11 Comments
have you tried another bnc cable?
Original Poster
mikey_d

have you tried another bnc cable?




Yes I tried that as I thought that might be the problem, I have three and tried two of them. Really annoying as the Sannace camera at 9000tvl got good reviews and was reduced from £50 to £20! The DVR was only £40 but seems to work its just not displaying the camera.
If you have proved its not the camera or the cable, then its pointing to a faulty DVR, I assume the 2nd camera you tried is a known worker
Original Poster
mikey_d

If you have proved its not the camera or the cable, then its pointing to … If you have proved its not the camera or the cable, then its pointing to a faulty DVR, I assume the 2nd camera you tried is a known worker



Ah that is the problem, I actually tried a third camera too, another Swann camera but a different model to the second camera I tried. Is it likely or a common problem that BNC cables go wrong?

Floureon DVR's are pretty much a non-brand and I bought this one for £40 (best offer down from £50).

Might just stop faffing about and give up with CCTV altogether! Sigh
Hi
I've had the same problem before.
It looks like you got a HD DVR recorder and slandered cameras I would say that is your problem.
you could take it to a CCTV shop to see if that is the case.

Original Poster
Slandered? (I haven't insulted them ha ha)

What about this kit

amazon.co.uk/Sur…ctv
Graham1979

Ah that is the problem, I actually tried a third camera too, another … Ah that is the problem, I actually tried a third camera too, another Swann camera but a different model to the second camera I tried. Is it likely or a common problem that BNC cables go wrong?Floureon DVR's are pretty much a non-brand and I bought this one for £40 (best offer down from £50).Might just stop faffing about and give up with CCTV altogether! Sigh


I wouldn't expect all three cameras and all three cables to be faulty, and the signal is just a composite video signal, so any camera that uses an analogue signal should work, just the quality of the image will differ, I think you have just been unlucky, and I would contact the DVR seller and discuss getting a replacement
Original Poster
Thanks Mikey D, I will contact them via their ebay store!
Hi Graham,
I am having the same problem. Got an 8 channel Sannce system with four cameras. Then tried to upgrade with 2 high spec Floureon cameras. The floureon cameras are powering up but no signal therefore no recording. How did you resolve this?
I have a problem with my new floreon circ system, I power it up floreon appears on the screen then I loose signal any idea?
sharon.watson11th Nov

I have a problem with my new floreon circ system, I power it up floreon …I have a problem with my new floreon circ system, I power it up floreon appears on the screen then I loose signal any idea?


Exactly the same problem with my AHD 8CH Floureon system sod with toshiba 1tb HDD drive - did you get it sorted?
Post a comment
Avatar
@
    Text

    Top Discussions

    Top Discussions

    Top Merchants