Ford KA Speedo/Dials light

2
Posted 12th Dec 2019
Bought a second hand car today. Obviously I will be contacting the seller tomorrow. But when driving tonight the Speedo light came on then went off not long after driving. All the other lights work fine.

I was just wondering if this is a common fault on a KA MK1. I was thinking maybe it was a fuse but surely it wouldn't come on intermittently? And if it's the bulb the same goes. Only logical thing could be a loose connection somewhere.

Hope this won't be a major problem and the seller can sort for me.
Community Updates
Ask

Groups

2 Comments
Maybe the contacts on the bulb have become a little worn or corroded and although the bulb will be cheap to buy and easy to replace once exposed getting to the actual bulb will be the problem as the dash will need to be stripped down in order to get to the instrument cluster
ding12/12/2019 08:46

Maybe the contacts on the bulb have become a little worn or corroded and …Maybe the contacts on the bulb have become a little worn or corroded and although the bulb will be cheap to buy and easy to replace once exposed getting to the actual bulb will be the problem as the dash will need to be stripped down in order to get to the instrument cluster




I think that's the case, it's on same fuse as side lights. They work ok. Apparently it's common for them to over heat and bubble the plastic. Which messes up the connection. Need to take stereo out etc to get to the cluster. The chap I got it from said he will hopefully sort it out. I would have a go but not got the removal tools :+
Post a comment
Avatar
@
    Text

    Discussions

    Top Merchants