GMAIL on phone attachments

12
Found 15th May
For some reason, Whilst I'm on the Mobile Network, gmail attachments dont download when I click the download button.

They download when I have a WiFi connection, But NOT when I'm using the Mobile Network Data Connection.

The Mobile Data is on and is working in all other Apps.

I have a Huawei P9 phone.

Its getting really annoying as I read an email but cant see attachements when I dont have WiFi.

Googling did not really provide a solution, I have reset the cach and app data for gmail... still no joy.

Any ideas would be greatly appreciated.
Community Updates
Ask
12 Comments
is it attachements or images?
for attachements it will be true. I dont think it would be a good idea to have auto attachement download when some of them could be quite large and eat up all the data
Edited by: "mattsk" 15th May
Both Images and Attachments.

Auto downloadis not the issue as I agree thats a problem in its own right.... But it shown a "Download Arrow" and a "Drive" icon on the attachement.If I click the download arrow, I would expect it to download it.

Sometimes you are out and about and know its a small attachment that you need to view... I cant download it... Until I get a WiFi signal.
Think drive is Google cloud drive. You download it to cloud drive where you can open and edit if required. Or download to phone and it will be in your download folder. Go look there. Sometimes nothing happens when you click download like on a pc when it will open automatically so when you look in download folder you have a bunch or duplicate files you've downloaded
Edited by: "wayners" 15th May
When I click on the download arrow, the attachment does not download into the Download folder. However on WiFi if I do the same, its there in the Download folder.
OK. Go look at settings
Installed apps. Gmail. Go look at the data restrictions and app permissions to see if all looks good. Maybe you have restrict background data on or something. Or storage problem. Clear cache while your there to
Edited by: "wayners" 15th May
Thanks waynerstried all that. Its baffling!
tmohammad4 h, 31 m ago

Thanks waynerstried all that. Its baffling!



Did you try, open gmail app, go to settings, click on your email account (not "General settings")..scroll down and untick as below? Also if an image, change setting to "always show" under the Images option like below.

33803390-kIDtZ.jpg
Thats like my settings
tmohammad1 h, 20 m ago

Thats like my settings



After that in Android you only have another few settings which you have said you already tried. (Other than no data on network but you have said other apps work fine)

In device settings>Apps>Gmail>Data> allow background data useage.
In device settings>Apps>Gmail>Data> allow app to override data saver mode.
It cannot be device memory permissions since it works over WIFI.
Only other thing which may confuse and is an unknown could be a security/antivirus app/Battery saver apps...but again doubtfull since it works over WIFI. Same with lack of app to open attachment ruled out since works over wifi.
Edited by: "cecilmcroberts" 15th May
Thanks to all that have advised how to resolve this. But its still brolken! I just realised that Google Play Store Updates dont download too over the Mobile Network even when I ask them to download!

Something is wrong somewhere. Either I'll just live with the problem or I may end up factory resetting the phone.

Thanks again to everyone for your help.
tmohammad24 m ago

Thanks to all that have advised how to resolve this. But its still …Thanks to all that have advised how to resolve this. But its still brolken! I just realised that Google Play Store Updates dont download too over the Mobile Network even when I ask them to download! Something is wrong somewhere. Either I'll just live with the problem or I may end up factory resetting the phone.Thanks again to everyone for your help.



Ahhh, that information actually helps. Check apps data settings for "Google play services" in the same manner.
Edited by: "cecilmcroberts" 16th May
Have done and its as I would expect it.
Post a comment
Avatar
@
    Text

    Top Discussions

    Top Discussions

    Top Merchants