Groups

    GTX 6600 and PSU

    I bought a gtx 660 ftw second hand from eBay. I realised that my PSu wasn't good enough, so I bought an aerocool integrator 500w, which has 36amp on 12v. Evga site says minimum is 450w with 24amp on 12v.
    The card is not recognised by the bios or in device manager. The fan spins but that's about it. I emailed the guy saying not working, and he emailed back saying I need a 1000w PSu, and stuff.
    Am I right to think it is broke, or should I invest in another power supply?

    10 Comments

    Know anyone who can test it on another pc? No single consumer gpu needs a 1000 watt psu so the seller is stating bs. I would begin a PayPal claim as faulty and show the recommended power use on the nvidia site as proof

    Lol 1000w.

    emodan

    Know anyone who can test it on another pc? No single consumer gpu needs a … Know anyone who can test it on another pc? No single consumer gpu needs a 1000 watt psu so the seller is stating bs. I would begin a PayPal claim as faulty and show the recommended power use on the nvidia site as proof


    I agree, sounds faulty but although the 1000w PSU is a load of rubbish it could be another component causing the issue. Would be ideal if you could test in another P.C but if that's not an option I'd return it. I'd imagine seller wont have a problem if he knows it works and can sell it again.

    Your power supply powers your whole system so without knowing the rest of the components it's impossible to say. Any figures quoted by manufacturers etc. are just guidelines based on some common worst case setup.

    The GTX 660 itself draws around 130-140W maximum.It's quite reasonable to run it on a 250W or 300W PSU if the rest of the system is fairly minimal and power efficient.

    I take it that if you plug your screen into the card you just get a black screen?
    Edited by: "EndlessWaves" 12th Aug 2016

    you can figure out what psu you need here LINK
    Edited by: "jimhuf" 12th Aug 2016

    Did you plug in the 6 pin power connector? It wont run without it.

    Original Poster

    I have plugged the 6 pin power connector in yes. I just put all the details in jimhufs link and says I would need 413w for my setup. I have an as rock h61m motherboard, an I5 2300, 8 gb ram, an ssd boot drive, and a couple of Sata hard drives. If I do go for a better PSu, would anyone suggest a reasonably priced one?

    So you've installed the drivers and connected your monitor directly to the card?

    Original Poster

    Yes by hdmi and Dvi/vga convertor to a monitor. Drivers installed, nvidia says no GPU. Doesn't show in device manager either.

    I would return it for sure. Buying another PSU won't help if the thing is broken/faulty. Seeing as the guy said you needed a 1000watt PSU I am gonna say hes trying to fob you off and he knows the item is broken/faulty when he sold it. As no way in hell does it need anywhere near that much
    Post a comment
    Avatar
    @
      Text
      Top Discussions
      1. I want to talk about the WEATHER no politics no religion19047077
      2. miikeyblue and shabbird's (but mostly shabbird's) Tuesday night pub quiz!553746
      3. Royal Mail chat says I am not allowed to send paper of any kind to Hong Kon…1838
      4. The HUKD Student Discount code sharing thread (most codes on Unidays are si…7041336

      See more discussions