Groups

    hdmi marrix issue

    Hi im looking for a solution to my problem, ok here goes.

    I have 2 4k hmdi matrixes 1 has sky hd connected to 3 tvs 1(living room) sony 4k tv, 2 (kitchen) samsung d8000 full HD, 3 (bedroom) hd ready. Right thats the tvs out the way here is the problem.

    Everything works perfect on TV1, but turn on TV2 ( without TV1 being on )everything works fine for a few short minutes then the screen keeps going black like its loosing signal, turn on TV1, and the problem goes away,

    Turn on TV3,same problem unless TV1 is on, aslo if i put a HD chanel on TV3 the sound is like a spitfire propeller but works fine on none HD aslong as TV1 remains on,

    Now ive just connected a 4th output an Epson Full HD projector this also has the same problems as TV3 the sound issue on HD channels. I initially put this problem down to the fact the 3rd TV is only HD ready but then again sky is only 1080i so now not sure whats going on with the projector.

    2nd HDMI matrix is also doing the black blinking screen every few secconds this is a Pc going to same outputs display set to 1080i. Works fine if TV1 is on,

    Ive turned off HDMI control on Tvs 1 and 2, apart from that i really dont know what to do,

    All HDMI cables are good quality high speed version 1.4, Tv1 cable is 15m, Tv2 is 15m, Tv3 is 7m and Projector is 45m with built in signal booster.

    Anyone any ideas im going crazy.

    Thank you and sorry for the long post.

    5 Comments

    I think the black blinking is HDCP protection kicking in.

    I had same issue, had to buy a booster to allow for cable lengths and HDCP. I used this box and now works perfectly.

    ebay.co.uk/itm…843
    Edited by: "stoneblade" 13th Jun

    Original Poster

    stoneblade

    I had same issue, had to buy a booster to allow for cable lengths and … I had same issue, had to buy a booster to allow for cable lengths and HDCP. I used this box and now works perfectly. http://www.ebay.co.uk/itm/252750652843



    This is the One I have. Do you know what's different.

    Belfen1x8 Powered 1080P V1.4 Certified HDMI Splitter with Full Ultra HD 4K/2K and 3D Resolutions amazon.co.uk/dp/…E80

    Thanks

    CUFC01

    This is the One I have. Do you know what's different. Belfen1x8 Powered … This is the One I have. Do you know what's different. Belfen1x8 Powered 1080P V1.4 Certified HDMI Splitter with Full Ultra HD 4K/2K and 3D Resolutions https://www.amazon.co.uk/dp/B01AHHMZAI/ref=cm_sw_r_cp_api_kb.pzb5YFVE80Thanks



    I would say if you have that one it would be down to the quality of your HDMI cables. If they are skinny thin things they probably wont be shielded. The longer the cable the more signal loss will occur, and with no shielding you will loose alot more from outside interference, especially 4k over a long length of wire. The only other thing would be the box you have is faulty?

    Just looking at some of the reviews on the one you have it it says a couple of times problems with the HDCP not handshaking properly. I noticed none of your devices are 4k (unless you meant sky q), so might be worth swapping to a cheaper booster and seeing if it works better, thats what I would do.
    Edited by: "stoneblade" 13th Jun

    Original Poster

    Thanks for that

    I have A pc connected to the other 1 and it does the same. The HDMI cables are high speed good quality and were not cheap. I've sent 1 back and gonna try the 1 you suggested and see if that helps
    Post a comment
    Avatar
    @
      Text
      Top Discussions
      1. One for the mathmeticians78
      2. The HDUK home for Star Trek: Discovery1218
      3. SNES Classic launches 29th September 2017 - Check for stock and pre-order i…4671414
      4. Meerkat Movies (2 for 1 Cinema Codes) | Official Trading Thread424614496

      See more discussions