Posted 28th Nov 2022 (Posted 18 h, 47 m ago)
I think my phone (Honor 10 Lite) just died

It was working fine. The battery was down to 5%, so I plugged it in to charge as normal, but a few seconds later I heard the beep and vibrate of the phone switching off. Now it doesn't seem to do anything when I plug it in.

If I press the power button the red charging light flashes for a second and the red charging logo appears on the screen for a second. After a while plugged in the logo changes to green, but then returns to red again. I can't seem to get it to do anything else. Holding the power/volume button occasionally makes it vibrate.

Anyone had a similar experience? Is there any way to revive it?
Community Updates
Ask
New Comment

27 Comments

sorted by
Avatar
  1. Avatar
    you may have tried some of the things in here but not all
    thedroidguy.com/how…916
    go through each one systematically one by one exactly as stated - be calm and patient - do not cut corners. you just may need to accept you have lost data; there may be a way of accessing the files when connected to a PC?
  2. Avatar
    Had Honor 8X sounds excatly same like my issue... It was damaged charging port (knew it for couples of weeks) didn't bother to fix it till drained the battery to 0% and then didn't want to charge.... Changed the port and its working nicely. Still going strong as emergency backup phone till today 😁
    Avatar
    Author
    This is what I'm thinking now with a bit more clarity than the middle of the night! I remembered suddenly that when I've been using an OTG cable recently it got more and more unreliable and then stopped working altogether, although no issue with charging at that point. So presumably this is just progression.

    How costly was the repair? Did you do it yourself? Charging boards for this model are cheap but even getting the back off looks like an ordeal.
  3. Avatar
    If it is a charging port issue.. maybe try a wireless charger?.
    Avatar
    Second this, get a cheap wireless charge from the supermarket. Leave it for a good few hours and see if it powers up
  4. Avatar
    I had the same once, there was pocket fluff in the charging port, it didn't look like it, bit I stuck a pin in and slowly moved it around the outside, the amount of fluff that came out was shocking.
    Avatar
    Author
    Another thing I tried quite early on. Didn't seem to make any difference, sadly.
  5. Avatar
    Sounds like a silly question but have you tried a different charger?

    Edit: Or leaving it on charge for longer to see if the battery was severely drained? (edited)
    Avatar
    Author
    It's been charging for hours. I've tried 3 different chargers and cables plus a laptop USB. Doesn't seem to make any difference

    It wasn't severely drained as i was literally using it 30 seconds before it powered off.

    I've moved onto another phone and I've always been led to believe that setting up a new Android nowadays is a seamless process with data, accounts and files being restored from the cloud. It's downloaded some of the apps from the old phone but that's it. What a nightmare...

    I've been meaning to set up the new phone for weeks but never quite got round to it. Now it looks like everything is lost. (edited)
  6. Avatar
    Try holding power and volume down button to start it up
    Avatar
    Author
    Tried that too. It won't do anything other than flash the charging light, show the red charging symbol, and vibrate briefly.

    Just noticed some things weren't actually backed up to Google Photos. (edited)
  7. Avatar
    Figure out how to boot into recovery mode. You might be able to forcefully power it off/boot it up, or if worst comes to worst, reset your phone.

    Similar thing happened to my OnePlus. Phone was low on charge and it just started bootlooping and would barely show the splash screen. Connect it to a PC, leave it in charge overnight then let the phone die completely if possible, hold all the buttons on the phone at once, and maybe even wait a day or 2 see if that somehow magically fixes it?

    And last resort, get someone to remove the battery and put it back in, that might do something. I've never once seen a phone suffering from booting issues not launch into recovery mode... So see if you can get into it first. (edited)
    Avatar
    Author
    Not enough power to try Recovery.

    I suspect it's not so much a booting issue as a power issue. Even while it was on and plugged in for a few seconds it didn't charge. Now that may have been because the connection wasn't quite fitting right at the phone or the cable into the plug, but it's impossible to know as the battery was so low it only lasted a few seconds after I plugged it in.

    Leaving it for a day or two is the only thing I can try now. In the meantime, this transfer process has been a mess! (edited)
  8. Avatar
    Try a different charger. Couldn't revive my Kindle Fire using 2.4A Anker charger, but when I left it on my Fire Stick's 1.8A hour charger for a few hours it came back to life.
    Avatar
    Author
    Interesting. A lower power one. That was why i tried the laptop USB port, but not for very long. 
  9. Avatar
    Has the battery been draining quickly over the last few months?

    If so, can be a sign it needs replacing.
    Avatar
    Author
    Not particularly, for a 3.5 year old phone.
  10. Avatar
    Could be a faulty charging port? Have you tried cleaning the port and perhaps moving the charging cable around whilst plugged in at different angles to see if you can get it to charge just a little bit
    Avatar
    Author
    Tried that. No change that I can see and if it isn't a faulty charging port I don't want to end up breaking that too by wiggling things around too much! (edited)
  11. Avatar
    My phone died but I have managed to fast boot it and now working fine. Fingers crossed
    Avatar
    Author
    If I could get it to the point where it was doing anything other than flashing notification lights, I'd be delighted!
  12. Avatar
    Warranty claim?
    Avatar
    Author
    Warranty ran out last year. The phone has been on its last legs for a while, but it's only now it's died that I realise how much was never actually backed up to the cloud so I could do with getting back in...
  13. Avatar
    did you Wipe the cache partition of the phone?
    • Turn off your phone.
    • Press and hold Volume UP button along with Power button on your device simultaneously for a few seconds
    • The phone will enter the stock recovery mode
    • Use volume buttons to highlight “wipe cache partition” and use power key to select it
    • Reboot the system once the process is completed
    Avatar
    Author
    Nothing like this is possible as it doesn't seem to want to do anything except show a red charging symbol, and vibrate.
  14. Avatar
    Author
    As if this couldn't get any worse a day, all of my app bank accounts are refusing to let me back in. If they're app only banks, you'd think they'd be prepared for sudden catastrophic device failure
Avatar
Top Merchants