HELP !! PS3 picture flicker and screen going blank

11
Found 15th Jan 2009
Hi there,

Noticed this problem last night while watching a movie via usb stick. PS3 connected via HDMI lead - the picture started flickering and dropping out - coming back on - then eventually going completely blank with no output detected.

I then noticed that the hard drive light on the PS3 was blinking like mad - when it stopped, the PS3 screen came back on - no messages etc.

I then started watching the film again, and this fault reoccurred a further 3 times before I gave up.

I checked the HDMI lead was secured properly at both ends, and cannot think of any other reason for the failure - checked for any updates, none available.

Anyone got any experience of this, unsure as to whether the machine is under warranty or not.

11 Comments

as long as the warranty is still in date then yea, this fault sounds like it'll be covered.
Does it only happen when watching a film via usb. What about dvd/bd's or when you're playing games?

check the settings in ps3(which deal with TV etc) if you recently altered any of them as there are quite a few that seem to do nothing. If you have an Hdmi switch box try a different port.

Haven't seen this before... Have you tried copying the movie to the PS3 HDD and playing it? Does it do the same thing? If it plays fine I would say it would be a problem with the usb stick or something along the lines of that.

Original Poster

Wee bit more info.

It's an HDMI direct connection to the panel - first time I've ever seen this was late last night watching the avi from the usb stick.

Once I had rebooted the PS3 - and sometimes after a long wait, it would play again - the same scene on the movie was perfect - but then 10-20 mins later the problem would happen again.

It happened 4 times during a movie lasting 1h50m.

I had previously not changed any settings on the PS3.

I will need to go back again tonight and check it out more with difference source material and maybe the other HDMI lead I have. Just thought I'd throw this out here in case anyone else had heard of this problem.

Probably worth getting it back to Sony if it's still under warranty..

Are you using a Samsung LCDTV by any chance?

Original Poster

Alfonse;4077080

Are you using a Samsung LCDTV by any chance?



Nah, it's a Pana Plasma - I've read up on HDCP handshake stuff etc - doesn't really sound the same problem.

moob;4077146

Nah, it's a Pana Plasma - I've read up on HDCP handshake stuff etc - … Nah, it's a Pana Plasma - I've read up on HDCP handshake stuff etc - doesn't really sound the same problem.



ok dude

Original Poster

OK got back and tried the trick with removing the hdmi cable - no joy - used a different disc rather than usb - no joy. Played same movie through my dvd upscaler - works fine on it's hdmi port. Just running a test via the other hdmi port using the dvd player to see if its a fault with the hdmi port on the plasma.

EDIT: Found my receipt - it expires on 17/1/09 - does anyone know if I could take it back to HMV for a replacement or do I need to go through Sony?

moob;4081220

OK got back and tried the trick with removing the hdmi cable - no joy - … OK got back and tried the trick with removing the hdmi cable - no joy - used a different disc rather than usb - no joy. Played same movie through my dvd upscaler - works fine on it's hdmi port. Just running a test via the other hdmi port using the dvd player to see if its a fault with the hdmi port on the plasma.




Thats what you need to do with all of them swap em all over try each in each to get to bottom of it.

make sure you also use the ps3 hdmi cable on another piece of equipment and vice versa

MooB'Sta

This is a common issue with certain HDMI cables, if you have a long or a cheap quality hdmi cable you will get this happen after some time. You simple solution is to swap out the HDMI cable and see if you have a day without any problems.

Post a comment
Avatar
@
    Text