Groups

    Help with hard drive permissions!?

    My laptop wouldn't recognise my 6GB IDE hard drive with windows xp installed, so I put it in my external hard drive USB case. My other laptop recognises the external USB hard drive however when I try and open my folder it says "Permission denied", all other folders are accessible.

    eg, My user name is Ryan, and I cant open c://documents and settings/ryan

    Any one know how to get round this? I really need a file in there.

    14 Comments

    Banned

    Are you trying to access it from XP home edition?

    I think it's something to do with the password set on the user account.
    For example, if a password is on your account, it wont let anyone but 'Ryan' or 'Administrator' look in those files

    Banned

    I think it might a setting on your pc and that it may still be seeing hard drive as a 'foreign' hard drive.

    go to control panel - administrative tools - computer management

    select the tab for disk management and right click on the new hard drive and see if it is set to view it. If not click import foreign disks.


    hope this helps

    Banned

    ^^^^Im talking about it being IDE there

    Original Poster

    salder21;2916690

    I think it might a setting on your pc and that it may still be seeing … I think it might a setting on your pc and that it may still be seeing hard drive as a 'foreign' hard drive.go to control panel - administrative tools - computer managementselect the tab for disk management and right click on the new hard drive and see if it is set to view it. If not click import foreign disks.hope this helps



    It lets me view the drive however still doesnt let me view the file. Im using win XP PRO SP3. Thanks for the help so far!

    The actual answer is that the drive has NTFS file permissions set. This is a security feature. I don't remember off the top of my head how to reset these permissions. But now you have the answer, surely google is your friend.

    An easy option is to put it back into your laptop and use the XP CD to run a repair operation on the drive.

    You could download a linux live-CD with tools to read the NTFS partition - such as ]BackTrack - then copy the files to another external drive, USB stick or a non-protected part of the file system.

    Original Poster

    jah128;2916948

    You could download a linux live-CD with tools to read the NTFS partition … You could download a linux live-CD with tools to read the NTFS partition - such as ]BackTrack - then copy the files to another external drive, USB stick or a non-protected part of the file system.



    I have backtrack in my cd collection I never thought of using that, I thought that windows would handle it better as it had windows installed on the hard drive. I'll pop backtrack in and see what happens. Thanks again!

    No probs - I think another option might be using the recovery console (boot from XP CD with the drive connected and it will look for Windows installs and FWIR lets you 'log on' to a particular account, but in my experience the Linux method actually works better!)

    Banned

    I think you just need to turn off simple file sharing & change some permissions, then you can access the folder.

    This explains it better than I can
    support.microsoft.com/kb/…874

    Banned

    Take ownership of the folder in question.

    The security features of any file system are rendered useless once you boot into another OS; Linux won't obey the NTFS security so you should have no problem reading any files on the drive. The only issue I can think of that'd create a problem would be encrypted files but that's a whole other topic.

    As long as you're an Administrator within Windows you can control, modify / reset any restrictions.

    Banned

    Heavertron;2916893

    The actual answer is that the drive has NTFS file permissions set. This … The actual answer is that the drive has NTFS file permissions set. This is a security feature. I don't remember off the top of my head how to reset these permissions. But now you have the answer, surely google is your friend.An easy option is to put it back into your laptop and use the XP CD to run a repair operation on the drive.



    I think that can be changed at the computer management section that i mentioned earlier too

    Original Poster

    Linux had no probs bypassing NTFS!!! Got my files back! Thank you!

    Banned

    In windows Explorer go to tools, folder options, advanced (I think, I'm running vista now) untick simple file sharing then press ok

    now

    right click the drive>properties> security tab>advanced > owner tab> at the bottom click on Edit

    where it says change owner to click your name tick the box that says "replace owner on sub containers and objects" then press OK. It will now replace all the permissions on the files to give you access.

    You'll get boxes that look like this

    http://img218.imageshack.us/img218/2009/74908522uz6.png
    Post a comment
    Avatar
    @
      Text
      Top Discussions
      1. Just heard this...2 ★★★★★★★★★★★★★★ congrats to all on 392k ★★★★★★★★★★★★★★7764206
      2. Microsoft Gamescom - Possibly more free games / Project Scorpio44
      3. ❅☁☁❅ I want☼to talk☼about the☔WEATHER☔no politics☃no religion❅☁☁❅18846165
      4. How dangerous is Donald trump?31136

      See more discussions