Help-Xbox 360 won't turn on!

49
Found 3rd Sep 2010
All i did was play a bit of Rock Band then moved the xbox to a different room- Help please!

49 Comments

Plugged in?

Original Poster

Yes

put it in microwave for ten minutes on full power to recharge it

Is the orange light on on the power brick?

wickedteen

put it in microwave for ten minutes on full power to recharge it



X)

Have you checked if the power plug is in correctly in the back of the 360 and on the brick? Is there a switch on the brick (can't remember) and is it turned on?

lol basics

Try connecting it to the same place as it was before & see if that works. If now try changing the cable that connects to the powerbrick & the socket. Just to make sure that the fuse is not gone. You can use normal kettle cable for it

Original Poster

Orange light is on

If thats the case than make sure its properly connected to XBOX. check this MS support link.
Your text here

If thats the case than make sure its properly connected to XBOX.

The power supply light is orange for one of the following reasons:

* The console is turned off.
* The power supply is not plugged into the console or the connection is not tight.
* The power supply is not functioning properly.

Note An orange light usually indicates that the power supply is connected to electricity and ready to power the console. When you turn on the console, the power supply light should change from orange to green
Edited by: "Iru786" 3rd Sep 2010

Original Poster

It is.

that0nehurts

It is.



It is what?

Original Poster

It is plugged into the xbox

Are you connecting it to a socket using a multiplug connector? if so try connecting it just by itself.

Original Poster

Nope, not working by itself either

Does the console do anything when you try and turn it on?

Original Poster

Nope

if this is brand new xbox than i would take it back to the store.

Well if the power is plugged in to the console and the power brick light is on then something must be physically broken. Be it the power switch on the front of the console of the cable going from the powerbrick to the console.

Have you tried turning it on using a controller rather than the front button?

Original Poster

Yes i have tried that, didn't work tho, had it more then a year so can't take it back

Got a friend with a xbox so you can try parts? Try your PSU with their console and your console with their PSU. See which (if either) is faulty.

does any of your mate have xbox ? If so i would try starting it up using their power brick. May be something is wrong with the cable between power brick & xbox.

Original Poster

Ok i'll try that- rep given to all that have tried helping

Original Poster

Doesn't work with there's either

Call Microsoft
Or if it´s less than a year old take it back to the shop you bought it at and get a replacement.
Edited by: "TanyaSpace" 3rd Sep 2010

Original Poster

Had it almost 2 years

that0nehurts

Had it almost 2 years



You get 3 years Microsoft cover (for certain things anyways), get on the site and have a look!

Original Poster

For RRoD that is.

Yes 3 RLOD and E74.

Original Poster

I have neither tho

that0nehurts

I have neither tho



Worth belling them up or emailing them tho, I know of a couple of people who have had fixes done free of charge by them

Original Poster

But my xbox is flashed

buy a new 1 in cash from tesco swap it over tell ur mum to go get a refund for it problem solved

that0nehurts

But my xbox is flashed



d'oh!

Have you tried pulling the power cable from the back and pushing it back in again to make sure it is fitted correctly, also is the HDMI (or whatever) connected to the TV. If you power on the console with no TV connection I don't think the front lights up properly.

Original Poster

Ungreat - Sep 04, 2010 10:42Have you tried pulling the power cable from … Ungreat - Sep 04, 2010 10:42Have you tried pulling the power cable from the back and pushing it back in again to make sure it is fitted correctly, also is the HDMI (or whatever) connected to the TV. If you power on the console with no TV connection I don't think the front lights up properly.

Yes tried that aswell, still nothing

I had the exact same issue this time last year but wasnt sure if it was a cable or console issue.

I randomly tested it a few months later and it worked.

Not that it was much help writing that but in my case it sorted itself out.

Original Poster

Didn't really help but thanks for giving me hope it works in a few weeks/month's :L

sell it on ebay as broek and get a new one

Clearly the op is hiding a vital part of the moving process.
Post a comment
Avatar
@
    Text
    Top Discussions
    1. water bill45
    2. fifa11
    3. 75% off Sky TV for existing customers. Only works when you call the specifi…18386808
    4. Without saying how old you are, Name one thing from your childhood someone …5998

    See more discussions