Unfortunately, this discussion is no longer valid
Expired

How to connect a a Sonoff S26 plug?

15
Posted 4th Nov
How the heck do I connect one of these bloody things? I bought these a while back for £6 and they never ever paired.

I’ve tried refunding it but due to complications I couldn’t return it so I didn’t even get my money back.

I’ve put it in pairing mode (blinks twice and a then steady pause and then repeat):

3324295.jpg



And I’m on my device waiting for it to connect:

3324295.jpg



But it always ends up failing why?
I wanna break this crap but I paid for it so I wanna get it to work. Anyone have any ideas please...

The only thing I think is wrong is that it should blink green not blue which makes me think that it has already been paired before and I can’t connect it to that’s why but I’m not certain.


Edit: I’ve got it to work now with an additional WiFi router (an old Sky netgear router - the one back in 2010s and stuff) connected to the main Virgin router (via an Ethernet cable) and figured out it’s to do with the Virgin router I have - which for some reason it won’t connect to directly.

So apart from my WiFi being exposed to hackers now since I’m using an additional ancient router - it’s fine I guess. No Siri support via (IFTTT/eWeLink) -> Siri Shortcuts (easily) but it works at least.
Community Updates
Ask
15 Comments
Bought one, it worked then one day no matter what I tried I couldn’t get it to re connect

Ended up binning it
ashmac04/11/2019 20:52

Bought one, it worked then one day no matter what I tried I couldn’t get i …Bought one, it worked then one day no matter what I tried I couldn’t get it to re connect Ended up binning it


I just got it to connect with my mobile data miraculously somehow but as soon as I disconnected it obviously and I’m trying again an it’s not working, fml
Anyone got any ideas on how to change the SSID on it?
If you have IOS I used the eWeLink app and then setup was easy
njl3004/11/2019 21:51

If you have IOS I used the eWeLink app and then setup was easy



The picture OP added is indeed eWeLink.

Stupid questions, but:
-Have you entered at step2 the SSID of your router and its password ?
-Then in step 3 have you set the SonOff in pairing mode ?
TobyZ04/11/2019 22:09

The picture OP added is indeed eWeLink.Stupid questions, but:-Have you …The picture OP added is indeed eWeLink.Stupid questions, but:-Have you entered at step2 the SSID of your router and its password ?-Then in step 3 have you set the SonOff in pairing mode ?


Oh yeah, sorry I didn’t click down. Yes indeed it is the eWeLink app. As far as I can remember my 4 sonoff’s connected very easily. I just followed the instructions. Sorry I can’t be more help.
There's two different connection modes, try both.
I’ve got it to work now with an additional WiFi router (an old Sky netgear router - the one back in 2010s and stuff) connected to the main Virgin router and figured out it’s to do with the Virgin router I have - which for some reason it won’t connect to.

So apart from my WiFi being exposed to hackers now since I’m using an addition ancient router - it’s fine.
dcx_badass04/11/2019 22:52

There's two different connection modes, try both.


There is only one mode that is supported for the S26, if I’m not mistaken
Smart plugs I’ve used don’t connect to routers that have 5ghz enabled.
I turned 5ghz off, set plug up and then turned it back on again.
Worked fine ever since.
GRSC04/11/2019 23:47

Smart plugs I’ve used don’t connect to routers that have 5ghz enabled.I tur …Smart plugs I’ve used don’t connect to routers that have 5ghz enabled.I turned 5ghz off, set plug up and then turned it back on again.Worked fine ever since.


My router is both 5ghz and 2.4ghz but I guess the plug only works on 2.4ghz sólo which is something I wouldn’t be willing to do, I mean I even tried it on a separate SSID but it just didn’t work on the Virgin router like I said - I’ve attached an ancient sky router wired to the virgin router and it works now
Have you tried turning off 5ghz, adding the plug and then switching 5ghz back on?
Thats how I got mine to work on my virgin router
GRSC05/11/2019 00:02

Have you tried turning off 5ghz, adding the plug and then switching 5ghz …Have you tried turning off 5ghz, adding the plug and then switching 5ghz back on?Thats how I got mine to work on my virgin router


Does yours work with 5Ghz on?
Yes
GRSC05/11/2019 07:53

Yes


Will try that one I’m home. Do you have any idea how to change the SSID on it or will I have to just re-pair it?
Post a comment
Avatar
@
    Text

    Discussions

    Top Merchants