I have a Xiaomi Note 4 with No Network problem

13
Found 27th Dec 2017
Now I got this phone after everyone raves about them on here
Global version Band 20
Red Global version sticker on corner of box
Note 4, 4GB/64GB
Android 7.0 NRD90M
MIUI ver 9.0.5.0

Issue: Tesco sim worked fine in iPhone5 prior to Christmas Day
Put it in the Xiaomi and it says Tesco in the top right, but says No Mobile Network when I place a call
No 4G, but if I can't make a call then no 4G is a no-brainer.
Tesco won't support the handset and say it must be locked if the iPhone works with the sim

Anyone any idea on what I have to do? Settings-wise?
Community Updates
AskElectronics
13 Comments
And you bought it from ?
Original Poster
Geekbuying

Exact phone I bought

Wait a minute.
The one I have been sent is a HK Global Rom. Difference between that and a "Global Rom"?
Edited by: "o1nk000" 27th Dec 2017
did you try a different sim ?
Original Poster
Yes. Tried an EE/Virgin pay monthly sim. That one gives No Service. Yet fine in my Galaxy. His sim is ok in his iPhone and not in the Note 4
Edited by: "o1nk000" 27th Dec 2017
same happened with me but talk mobile talked me through it,i had to go in access point names,and then they told me what to put in the various boxes ie password network code.then worked fine
Apn settings correct? Google apn settings for tesco network and check they are correct.. I'm on tesco with note 3.
Go to your device "settings"

Select "More "settings"

Select "Wireless and networks".

Select "Mobile networks".

Select "Access point names".

Now tap the menu key.

Select new APN.

Fill in the settings
Edited by: "wayners" 28th Dec 2017
Is the sim card in slot one ?


Keith
Original Poster
wayners12 h, 20 m ago

Apn settings correct? Google apn settings for tesco network and check they …Apn settings correct? Google apn settings for tesco network and check they are correct.. I'm on tesco with note 3.Go to your device "settings"Select "More "settings"Select "Wireless and networks".Select "Mobile networks".Select "Access point names".Now tap the menu key.Select new APN.Fill in the settings


Done it. Not edited the APN, but added a new one with all the settings from Tesco Customer Service.

Kipper:Tried it in Slot one and slot 2

It picks up the sim when I have my WIFI on. It even gives me 3 bars for 2G and shows I have 4G
Turn off WIFI and it shows "No Service"
BUT ..... with wifi on or off, it will not let me send a text or make a call

Either the Global rom is not a Global rom, or Tesco are useless.
Mind you, Tesco online chat stated the phone, and I reiterate this verbatim, "is locked".

Someone elsewhere stated modem drivers were an issue with MIUI8. But the phone updated to 9.0.5.0 as soon as my lad got it
What does it say in settings about phone Miui version field.

Kipper
Have you tried disabling VoLTE, a friend has to do this with his Xiaomi to be able to use it for calls/texts. The option should be in settings, if not dial * # * # 86583 # * # * then reboot your phone and the option should be there.
My brother had a Chinese phone with Chinese rom. Took him ages to work through the menu to find a way to switch it to English.. Lol... Anyway that worked out fine. Sounds like a fault with the phone as you should get it to work fine. Assume the phone is switched off when you inserted sim. You want to use slot 1. Heard a review of a oneplus 5t and the phone case stopped the signal. After hours on the phone factory resetting nothing worked. Only discovered it was the case while boxing up to send back. Have you tried a factory reset? That's all I can think off
Edited by: "wayners" 29th Dec 2017
Original Poster
Mad Kipper: MIUI version 9.0.5.0

dcx_badass : I know where VoLTE is (is that voice over 4G if you are in a dead zone or something?). I'll disable that and get back to you. Did your mate have the 'no service' that I have?

EDIT: VoLTE off makes no difference

wayners : done everything to do with sim and factory reset

Let me explain.
In Mobile and Networks it shows me O2 for MMS and Tesco prepay for the sim. This is selected.
In the list of networks, O2 is clear, EE, Vodafone and Three are 'forbidden'. Yet when I try to connect to the O2 network, it just won't register.

Thanks to all, by the way
Edited by: "o1nk000" 30th Dec 2017
Original Poster
Update

Took it to the Tesco Phone Shop this morning and they couldn't get any of their settings to work. Consistently No Network. Wouldn't even connect to the Tesco guy's Vodafone sim.
Tried a Virgin sim and it wouldn't connect either

Guessing something wrong with the global rom now?
As with Note 3, MIUI 8 and the missing modem drivers?

Sparked an email back to Geekbuying to see what they can do
Thanks all
Post a comment
Avatar
@
    Text

    Top Discussions

    Top Merchants