Induction hob not working on the left hand side

11
Posted 2nd Jan 2019
Hi, I have a Baumatic induction hob and have had no problems with it until now. The right hand side is working but the left hand side is not. Has anyone any ideas on what the problem could be? Thank you
Community Updates
Ask

Groups

11 Comments
I work on these hobs i would check the wiring coming to the terminal block first see if nothing is loose if that looks.all secure then most commonly with these are the power boards which power up the coil could also be faulty.
Avatar
deleted1471098
Use the right instead
Can you turn the rings on
Sounds like two triac transistors have gone as in blown on the left side. Exact same thing happened to ours on a Samsung. I took it apart and found them in bits but I couldn't get the exact same triacs value to replace them so binned it. Another problem these have is the magnetic base inside arcs and melts the wiring. Did it go bang on the left side.
Avatar
deleted1421316
Had 2 induction hobs do the same, apparently the power board each time? One was replaced under warranty, I was told it's not cost effective to repair out of warranty so I replaced the other myself.

No warning each time, just suddenly pop and it was dead on one side. Had been used daily without issues before that.
deleted142131603/01/2019 10:58

Had 2 induction hobs do the same, apparently the power board each time? …Had 2 induction hobs do the same, apparently the power board each time? One was replaced under warranty, I was told it's not cost effective to repair out of warranty so I replaced the other myself.No warning each time, just suddenly pop and it was dead on one side. Had been used daily without issues before that.


What brand was this?
Avatar
deleted1421316
Tea_minion7 m ago

What brand was this?


Pretty sure the first one was Indesit, that lasted just over 2 years and I replaced it with a cheaper beko, that lasted only 8 months so it was still under warranty luckily.
Hi, thanks for all of your replies, when the left side went off there was no sound or popping. My friend has checked underneath the hob and everything is fine all terminals are connected and not loose. There was an error code E2 flashing but I have no idea what this means. Thanks
Avatar
deleted1421316
wainfleet130 m ago

Hi, thanks for all of your replies, when the left side went off there was …Hi, thanks for all of your replies, when the left side went off there was no sound or popping. My friend has checked underneath the hob and everything is fine all terminals are connected and not loose. There was an error code E2 flashing but I have no idea what this means. Thanks


Abnormal voltage supply - check the mains according to a quick Google.

If it has been fine, not been messed with and now not working then it's probably had a failure of the power board.

I don't suppose it's still under warranty?

36731066-BiNoa.jpg
Edited by: "deleted1421316" 3rd Jan 2019
E2 error code is Overheating of the induction coils


36731091-2RYMO.jpg
Edited by: "fearona" 3rd Jan 2019
Post a comment
Avatar
@
    Text

    Discussions

    Top Merchants