IOmega External Hard Drive Problem?

16
Found 13th Jan 2009
I recently bought the 500gb external hd from comet and was really pleased with it.
Problem is I can't access it any more, keeps coming up with
'Windows cannot access the specified device path or file. You may not have the appropriate permissions to access them'
I've tried it in different usb ports but still the same.
Any ideas appreciated!

16 Comments

Tried a different USB lead?

Original Poster

dcx_badass;4053609

Tried a different PC?



Yes works fine

Original Poster

Shengis;4053652

Tried a different USB lead?



Yes same problem

Right click on my computer
click manage
click disk management
look and see what the status of the drive is,

Original Poster

tonyg1962;4054293

Right click on my computerclick manageclick disk managementlook and see … Right click on my computerclick manageclick disk managementlook and see what the status of the drive is,


Healthy, active, primary partion Fat 32

Have you tried simply restarting your PC ?.

Original Poster

tonyg1962;4054547

Have you tried simply restarting your PC ?.



Yes about 5 times now seems very odd just stopped working????

Try right clicking on the drive,
then properties
security tab
Edit button
if you are the administrator then every thing but
special permissions should be ticked as allow

Original Poster

tonyg1962;4054679

Try right clicking on the drive,then propertiessecurity tabEdit buttonif … Try right clicking on the drive,then propertiessecurity tabEdit buttonif you are the administrator then every thing but special permissions should be ticked as allow



Don't have a security tab, got general,tools, hardware ,sharing,ready boost ,customise

cycleman;4054754

Don't have a security tab, got general,tools, hardware ,sharing,ready … Don't have a security tab, got general,tools, hardware ,sharing,ready boost ,customise



Are you ,logged on as administrator ?

Original Poster

tonyg1962;4054784

Are you ,logged on as administrator ?



Yes...I think so same as I've always done, can I check?

Sorry you were right i was looking at it as an internal drive,there are no security settings for a usb drive,

Are you saying it works fine on another computer?

Can you try another drive or usb thumbdrive in order to see if your PC is allowing you access to anything else via usb,

Original Poster

Ok Guys thanks for all your help, don't quite know what happened but tried system restore as far back as I could go and now working:thumbsup:

Glad to hear it
Post a comment
Avatar
@
    Text