Groups

    iphone help:Navigation button not working and wont work with a usb?

    Basically my uncle tried addiing moblie me app and he may have upgraded the iphone but im not sure.

    It turns on and everything but the navigation button dont work and also its not recognized on the p.c.

    Is this iphone officially dead now?

    6 Comments

    can you get into your settings menu? if so you could try going to general then reset see if that helps restore it. ive not had any problems with mobile me. if that doesnt work try putting it into recovery mode and plugging it in.

    Original Poster

    It wont even allow me to put it in recovery mode. Each time i try it starts flashing with the ipod logo and and it comes up with itunes and a usb. I plug my cable in and it just stays at that screen. Ive tried it with a mac and normal desktop.

    Forgot to say this was the hacked iphone.

    Original Poster

    Its going mad now lol keeps on flashing now and then.

    I think i should organize a funeral for it.

    Original Poster

    bump it up

    It dont even turn on no more lol it wont let me charge it up.

    you could try this :

    hold down the top button and the home screen button at the same time for about 15 seconds and then RELEASE!

    also.......to charge it try the cradle charger instead of the USB cable.

    Original Poster

    Thanks ill try the charging because the battery was low before.
    Post a comment
    Avatar
    @
      Text
      Top Discussions
      1. Entitled to overtime to be included in your holiday pay1020
      2. Labour MP Naz Shah retweeted calling for abused white girls to shut their m…1536
      3. word association Game72944192
      4. Surprise! The HUKD Summer Flamedeer Hunt 2017 **OFFICIAL THREAD** (trading …277963

      See more discussions