Groups

    Is it me?

    Just bought an 80 gb USB hard drive from Amazon. Plugged it in to 1.1 USB port but is not recognised - no show at all. Supposed to work just by plugging in. I get the usual "this would work faster in a USB 2.0 port" but that's all. Tried everything on the cd but nothing helps. I get a green light on the drive and some vibrations that come in waves like its trying to load - like when you first put a dvd in the computer drive. Also tried plugging in the 2nd cable to give more power but thsi does not help either.
    Am I doing something wrong? Any suggestions?

    12 Comments

    Have you tried looking under computer management. you may find it has no partition on it. it could also be that it has tried to assign a drive letter that is already used.

    As said by nightbreed, as its a new drive you will need to format it, so that i creates a readable partition, then it should be picked up by your PC. Right click on my computer and then manage, then disk management

    Original Poster

    Thanks - have just been through computer management and have ended up with the message 'this device cannot instal' - have tried uninstalling and re-installing but no good.

    Original Poster

    All that shows on Disc Management is the main hard drive and the DVD drive.

    put it directly into one of the top rear ports after removing and rebooting, then wait two minutes

    Original Poster

    Not quite clear on that - 'directly into one of the top rear ports' - sounds exactly like it is at the moment.

    Banned

    buy a usb 2.0 card then lol

    Original Poster

    Yes - I've got one and it does not work in that either.

    is it powered by the usb port or does it have its own psu?
    if its usb powered then it could be that your pc isn't capable of providing enough power. a lot of external drives come with an adaptor that either sits on the keyboard port to nick power from there or has 2 usb plugs so it can use the power from 2 ports instead of one.

    Original Poster

    Thanks for suggestion - it is USB powered and it has got a 2nd USB lead which I have used but unfortunately it does not help.

    what version of windows is this?

    Original Poster

    XP Pro - eventually got it to work using both leads to get extra power. Thanks to all - rep added.
    Post a comment
    Avatar
    @
      Text
      Top Discussions
      1. Localphone VOIP long distance app broken (not ios11 compatible)34
      2. Amazon prime subscribe & save46
      3. Decent Mp3 Player?22
      4. What's the most impressive 4k / UHD film you have seen at home?610

      See more discussions