Groups
    EXPIRED

    Issue with Canon 17-55mm Lens? Won't auto focus at far distances.

    Any help would be much appreciated! So please if you know anything, please let me know, thanks!

    It is a Canon 17-55mm f/2.8 IS USM lens

    The manual focus works fine at any distance, however on auto focus, anything past 28mm it will not focus. It keeps focusing in and out.

    The image stabilization doesn't affect this. It can be on or off and it makes no difference.

    6 Comments

    Not sure bud, is the IR sensor on the camera covered / dirty - used for auto focus. Not sure about the settings? Do you have any other lenses to try: you could take the camera to a shop to 'try' a new lens but actually the main reason is to test your camera works properly. Also, what is the camera? Perhaps it's a known problem? How long has it been happening for?

    Original Poster

    redcastle

    Not sure bud, is the IR sensor on the camera covered / dirty - used for … Not sure bud, is the IR sensor on the camera covered / dirty - used for auto focus. Not sure about the settings? Do you have any other lenses to try: you could take the camera to a shop to 'try' a new lens but actually the main reason is to test your camera works properly. Also, what is the camera? Perhaps it's a known problem? How long has it been happening for?



    Thanks for your reply.

    It actually happened on my friends camera (it was almost new so Idon't believe it was the camera, along with that other lenses worked fine), I no longer have my 7D so I cannot test it myself - I was going to sell the lens but as I haven't used it for a while I tested it today which is when I found out.

    I'm going to borrow a camera later from another friend and see if the issue persists. I have Googled the issue and I see other people have had problems with the autofocus however not exactly related and it doesn't appear to be a common issue.



    Edited by: "joshp" 21st Jun 2014

    Original Poster

    Update, still the same issue with another camera so definitely the lens.

    Original Poster

    Another update: I have opened the lens to see if I could find anything wrong but it all looks fine. Upon replacing it and testing the lens, it now appears the lens is working at distance however i now won't focus between 20-50cm.

    Any suggestions please?

    Banned

    99% of the time its caused by dirty contacts on the body or lens

    Original Poster

    whatsThePoint

    99% of the time its caused by dirty contacts on the body or lens



    Thanks for the reply however I have tried the lens with 2 cameras so I know its not the body. I have also cleaned the contacts with isopropyl and they look fine.
    Post a comment
    Avatar
    @
      Text
      Top Discussions
      1. seller asked for IMEI1112
      2. Jersey uk deal please anyone33
      3. Sportsmania.eu down. Any alternatives?2545
      4. Decent hoover77

      See more discussions