EXPIRED

Just built a new computer and have no display

Banned
Just built a new computer and have no display.

Any ideas?

53 Comments

Buy one?

Original Poster Banned

emasu;2020686

Buy one?



Whats with all these **** posts as late?

Banned

Displays are for n00bs

jizzm;2020692

Whats with all these **** posts as late?



you have no display? what does that mean we need a bit more info, when i first read it, it sounded to me like you had no montior either.

Banned

jizzm;2020692

Whats with all these **** posts as late?



lol she beat me to it!

do you mean you don't have a monitor and want suggestions on one or do you mean you have built a PC and it isn't outputting a display?!

Banned

If the thread was worded better perhaps you would get the answers you want.

try hitting the side of your pc with a sitck

Original Poster Banned

morris7;2020705

do you mean you don't have a monitor and want suggestions on one or do … do you mean you don't have a monitor and want suggestions on one or do you mean you have built a PC and it isn't outputting a display?!



Isnt outputting a display.

I think its quite self explanatory tbh.

jizzm;2020710

Isnt outputting a display.I think its quite self explanatory tbh.


i refuse to help now.

Banned

I have a beer but no bottle opener.

Any ideas?

check your RGB pistons are firing correctly

is it inbuilt graphics or dedicated?

emasu;2020686

Buy one?



Get one free? hehehehehe

Onboard graphics? PCI-E graphics? What card? DVI, VGA? Any error beeps? More info needed..

Original Poster Banned

PCI-E graphics.
The card is a x1800Xt bought from leeredgie off here.
No beeps upon startup.
There is power to the gfx card, and fans are spinning etc.
Just no display on the monitor.
Ive tried onboard as well as gfx card graphics.

a lazy post gets a lazy answer from me.

Is the monitor on?

check if you have mains power in the house... power outage would explain everything

Banned

If you are getting no beeps on startup, then the graphics card isnt registering. Make sure nothing is shorting out and the memory and CPU is set firmly in their slots,

Check the Graphics card is fully seated within the port, check your monitor cable has damaged or missing pins and if you are using an LCD monitor some need drivers sop check you don't need to install any before hand.

One possibility is that if you use DVI, then your monitor might be set to VGA signal (or vice-versa).

Your not getting a boot upon startup?

That means could be anything wrong, do the fans just keep spinning upon startup? It does not mean theres something wrong with your gfx card if theres no display, u bios isnt booting for some reason. need more info rele

Banned

dude its probably your ram.. try one stick at a time.

tell us all the components

Banned

ps. all you guys are jokers... can't believe no one rickrolled him... noobs

black gerbil1;2020712

i refuse to help now.



Lmao!!!

Yeah mate your minimaly worded problem and your instant attitude aint gonna get you much help!

Proximo;2020696

Displays are for n00bs



black gerbil1;2020707

try hitting the side of your pc with a sitck



black gerbil1;2020712

i refuse to help now.



KillFelix;2020721

I have a beer but no bottle opener.Any ideas?



pmsl, think your self lucky dude, i bin on mse this afternoon and there is so much vicious flaming going on, a bit of ribbing from this lot is much more preferable.
But as hinted a bit more detail will get you further and PC building can be stressful so try and chill a bit

Banned

so what was the problem jizzm?

PM me if you still have a problem:thumbsup:

Jizm

Just one word and its probably the wrong one!

Drivers!
Can you check whats been supplied v's what OS you're running?

Does safe mode work,? (F7 (((???))) on boot up or enable in bios!

Original Poster Banned

Chidda;2021815

Your not getting a boot upon startup?That means could be anything wrong, … Your not getting a boot upon startup?That means could be anything wrong, do the fans just keep spinning upon startup? It does not mean theres something wrong with your gfx card if theres no display, u bios isnt booting for some reason. need more info rele



im getting all the fans upon pressing the power button.
Fans on the gfx card are working, power supply and the cpu heatsink fan.

When i press the computer button, the gfx card led comes on for a second then goes off.
Is this normal?
The ram issue, i have tried 1 stick, 2 sticks etc.
To no avail.

Try setting the PC with no devices connected Hard Drives, DVD drives, Keyboard etc.

If it still hangs try starting it up with no RAM, it should give you waring beeps.

Original Poster Banned

okay will give that a try, cheers stora

Original Poster Banned

right just tried that, i get nothing different when disconnected all the drives,
then upon taking the ram out, i get no beeps or anything.

Is your CPU seated correctly and is it compatible with the system board ?

Original Poster Banned

stora;2035380

Is your CPU seated correctly and is it compatible with the system board ?



Im just in the process of reseating it.
It is compatible with my board yes.

what is the make and model of your motherboard?

Is the chipset fan NB/SB under the back of the graphics card making it hard to tell if it's plugged all the way into the slot or not?

Do you have a 6 pin PCI-express power cable going to the card, so it is being powered from the PSU and not just the pci express slot?

If your board has more than one pci express slot, try the other one.

use the other dvi port on the back of the card

have you any other pci-express graphics cards to try in the pci-express slot? if so try that.

alternatively a 2mb vga pci card in a pci slot will get you into the bios.

Set the bios to 8x instead of 16x

Clear the CMOS by using the jumper.

while pressing and holding in insert on your keyboard, turn on your system and dont let go of the insert key till something comes up, this may take a few tries so dont rule it out on the fist attempt..

Failing all that, get back to me

oh, threads expired, did you fix it dude?

If so, what was the problem? any info may help out other users if they end up with a similar issue

Original Poster Banned

Hi dudes.
Ive sorted it!
WELL..
was readin through the manual, and forgot i had forgot to plug in the 4 pin power plug connector.
So plugged that in, turned on the computer.
And smoke started coming from the computer, i was like WTFFF?!"!!

Turned it off, in a panic.

Finally got a display.

The wire that got on fire, could that be down to a faulty power supply?

:thumbsup:

Original Poster Banned

does this mean i have a faulty power supply?
Post a comment
Avatar
@
    Text
    Top Discussions
    1. Just heard this...2 ★★★★★★★★★★★★★★ congrats to all on 392k ★★★★★★★★★★★★★★7763869
    2. New TV,Film & Ebook Releases 2407225
    3. GOT Leaks again414
    4. Xbox One X pre order £449.99 @ Game (out 9th Nov)2345

    See more discussions