Groups

    LCD DVD TV problem...DVD only shows pictures in Green colour?

    I just bought a LCD DVD TV about a week ago and its acting up. Everything worked well before but when I tried to use the DVD today, the only picture I see on the TV is in green colour only. I have been using the TV to connect using a VGA cable to my laptop as my second monitor and it works perfectly and its still working right now. But when I switch to DVD or TV mode, the picture is only in green colour.

    Does anyone know whether this is something I can fix such as changing the settings (I already tried to reset the settings to factory mode)? I unplugged the VGA cable and problem is still there? Or is this something I'll need to return back to the manufacturer in order to fix?

    17 Comments

    hmmmmm is everything set to pal? if the dvd is in ntsc it might be that.

    Are all conections conected?

    Slash have you powered down the LCD for say 10 minutes and tested it again once its been shut off for a while?

    Other than that I suggest you contact the manufacturer and ask what is going on.

    I used to get this problem way back when I had a PS1. NTSC signals go green on PAL TV's.

    Are you using any US hardware or DVDs?

    Original Poster

    Everything is plugged in correctly. I am using the same DVD that I used to test it when I first got the TV and it worked then but not now. Right now, Freeview and DVD both show picture in Green. Tomorrow is the last day for me to return the TV since its the 7th day and that's the last day to get a refund so trying desperately to see whether I can fix it myself so I don't have to pay to send the unit back to the store.

    Its something to do with the macrovision security on DVD's if i remember correctly.

    NTSC signals on a pal screen usually result in a black and white picture.

    edit: If your freeview box is also resulting in a green display then its something else.

    Try changing some settings (RGB to Composite etc) in the settings.

    Original Poster

    The tv has a dvd player and freeview built in already. It works when I connect it VGA to my laptop, works playing WII, and works if watching normal TV (NOT freeview). But it shows green colour when I try to watch freeview and when watching DVD. There are two lines connected to the tv; power and the TV cable and I made sure they are securely connected already. Any other suggestions or is this something I cannot fix? If everything on the TV is in green colour, then I would give up trying now but it is just not working for freeview and dvd!

    Original Poster

    PhearFactor;2742294

    Slash have you powered down the LCD for say 10 minutes and tested it … Slash have you powered down the LCD for say 10 minutes and tested it again once its been shut off for a while?



    I'll try that now!

    Oh, take it back then. Its faulty lol.

    Even if it works after powering down I would still take it back. The TV should be automatically set itself to the resolution and refresh rate for the signal. The display sounds as if it is stuck at whatever your computer was outputting via VGA, hence why that works fine there but when you go to Freeview or DVD and the signal is different the TV isn't switching itself to the correct output. Hence the green image.

    It sounds like a software fault or something on the monitor, it has just got stuck at the wrong resolution/refresh rate. Problem is, if it goes away there is no way to know if it will spring back up again in the future. So it is best to return it and get another one as this really shouldnt of happened.

    Original Poster

    PhearFactor;2742533

    It sounds like a software fault or something on the monitor, it has just … It sounds like a software fault or something on the monitor, it has just got stuck at the wrong resolution/refresh rate. Problem is, if it goes away there is no way to know if it will spring back up again in the future. So it is best to return it and get another one as this really shouldnt of happened.



    I unplugged it for about 30 min and the problem is still there. Would you suggest I just get my money back and not bother to exchange for another one of this same tv? Not sure if its just the tv that I have is faulty or is it likely that the problem will arise again if I exchange for a new but same model tv?

    I would go for another brand if you can. What set is it any way (brand, model number)?

    Original Poster

    PhearFactor;2742594

    I would go for another brand if you can. What set is it any way (brand, … I would go for another brand if you can. What set is it any way (brand, model number)?



    Its a Prestigio P200DVDW-XD from ]this thread

    Empire direct don't have it in stock anymore. I want to try and get them to exchange for a 19" of the same brand if they let me.

    Ah never heard of Prestigio. If you can get your money back do that. Generally I advise people to get cheaper branded electrical goods like this from Tesco/Asda/Argos etc (in-store if possible), you might pay £20-30 more but if it gets a fault its a hell of a lot easier to get it sorted.

    For example:
    asda-electricals.co.uk/sho…tml

    Original Poster

    PhearFactor;2742641

    Ah never heard of Prestigio. If you can get your money back do that. … Ah never heard of Prestigio. If you can get your money back do that. Generally I advise people to get cheaper branded electrical goods like this from Tesco/Asda/Argos etc (in-store if possible), you might pay £20-30 more but if it gets a fault its a hell of a lot easier to get it sorted.For example:http://www.asda-electricals.co.uk/shop/product/bush/idlcd19w016hd.html?



    Thanks PhearFactor, I'll contact empiredirect first and see what options I have. Thanks also for everyone for your inputs.

    I would suggest that its the ribbon cabling in the TV. As the VGA and and the other sockets work fine which are soldered onto the main board. The DVD drive and freeview tuner are ribbon cabled to the main board and one may be loose. This has been an issue on TV's that have been converted form monitor panels. I would send it back unless you can get the retailer to send somebody to check the internal connections. You could however open it yourself.

    If it's Green it sounds as if there is an alien living inside

    Original Poster

    Just a bit of an update.

    I phoned the manufacturer and was told the problem may be due to a connection problem inside. I then cheekily asked if this a common problem to which he responded the textbook 'No'. He actually never heard of such a problem before. Guess its just my luck?

    Proceeded to ask for exchange from the online store but there is no more stock and they wouldn't replace it for a smaller tv that also have the same functions as the one I got unless I pay £100 more. Of course I refused and will be sending it back via their courier tomorrow.

    I'm actually a bit tempted to just have the manufacturer fix it as its under warrantee since I will have a hard time finding a better price for a similar tv. Does anyone know if they fix a connection problem, is it something that will reoccur in the future or likely to be OK ?
    Post a comment
    Avatar
    @
      Text
      Top Discussions
      1. The HUKD Student Discount code sharing thread (most codes on Unidays are si…7261380
      2. word association Game74044574
      3. Giffgaff New goodybags33
      4. Santander - Compensation1617

      See more discussions