Lebara dropping calls after 30 min as company policy

Posted 26th Sep 2022
Hello anyone aware of Lebara disconnecting calls after 30 min automatically? even though you are on unlimited call plan.
Or any other UK provider doing such things.
Community Updates
New Comment


sorted by
's avatar
  1. JamesB83's avatar
    Been with Lebara for 5 months now and made several calls over 30mins without being disconnected
    skybluesccfc's avatar
    Yes I thought I'd update on our progress, but the hold on a call does fix it. Annoying but a workaround.
  2. chrb's avatar
    Hasn't happened to me on Lebara but only been with them just over a month but made calls 30min + with no issues (edited)
  3. SaturdayGigs's avatar
    I read some where before turning wifi calling off and restarting phone worked to solve this issue.
    brienglish's avatar
    Didn't work for me I still have the issue
  4. TristanDeCoonha's avatar
    Must be new as I talk to the old man for a couple of hours at a time
  5. pilan's avatar
    I have Lebara and was queued for more than an hour to speak to bank customer service. This happened 3 days ago. Didn't drop off.
  6. skybluesccfc's avatar
    We seem to be getting this in my wife's phone. WiFi calling is disabled
  7. Aady's avatar
    I am having this issue everytime when it reaches 30min.it's so annoying because sometimes I have to wait for more than 30mins to talk to customer service. Is there any fix ?
    N-V's avatar
    N-V Author
    I had similar issues and I can understand how painful when it disconnects while you are in between the discussion and you need to explain it all again to the new agent.

    You need to
    1. Login to your account and get the call log when the call was dropped (you may find 29:50 or similar)
    2. Talk to customer care and pin point the call drops, without the logs they may not admit its a problem at there end.
    3. Send a strong email to customer care but I bet they won't be responding to that.

    It took approx. 2 wk. to get this fix on my numbers. it was very painful even the calls to customer care were dropping after 30 min.

    As per customer care in recent months they had changes at there network based on some new policy they don't allow calls more than 30 min.
    I asked them to share the policy and as expected they never shared it.
    I challenged them that when I got the plan this was not in place and I should be allowed to make the calls as long as I have the plan or call credit.

    I had a few rounds with them but at last it seems working.
    Hope that helps.
  8. brienglish's avatar
    Lebara are insisting it is an Issue with my phone and they have had lots of reports for this on the Motorola G50 5G (which is Android). I'd be interested to hear what models are affected other than mmine. I'm currently negoatiating Motorola UK Support, not a great experience as it shuts at 6pm...
    N-V's avatar
    N-V Author
    Same story with me that Lebara says its the problem with the chipset used in the Motorola G 5g as well. it seems they are all in same class chipset. Lebara said they have escalated with Vodafone but no time lines to get that resolved with Vodafone and further with Motorola. Though earlier I use to make more than an hr longer calls till few months back. would be interesting to know if Vodafone customers are facing same issues.
  9. louiselouise's avatar
    Interesting - I thought it was just me, but discussing it on another thread and Googling it brought me here (didn't see this discussion originally).

    I have the Snapdragon 888 in my phone (ZTE Axon 30 5G - though - I never had calls getting cut off on GiffGaff / O2 network). I don't have Wi-Fi Calling enabled.

    Boyf says he's been able to hold 30+ minute phone calls (and he has a Huawei Mate 20 Pro - 4G) - the only long calls I ever see him doing are via Wi-Fi on Telegram? but I'll take his word for it. Maybe it does depend on your phone's chipset? Who knows!

    Edit: He's looked up his call logs and he's done a few really long calls recently (I must not be about when he makes them - maybe he's got another woman, ha).

    TL;DR: Sounds like it probably is a 5G chipset to blame. Wonder when Lebara / Vodafone will fix the issue? (edited)
    .MUFC.'s avatar
    I'm on Vodafone and my Xiaomi 12 cuts off after 30 minutes. The solution for me is to disable 4G and WiFi calling ( my phone is 5G capable but no 5G in area ).
  10. nokesy's avatar
    My calls randomly drop after 3-4 minutes, sometimes they last a bit longer. Driving me and my callers nuts! I’ve tried the Lebara sim in iPhone XS and iPhone 11 with same issue 
  11. Gohan123's avatar
    Also cut off after 30 minutes redmi 10c which dont have 5G and also no wifi calling enabled still cut off....lost my place in the que. (edited)
's avatar
Top Merchants