Groups

    Mechanic's advice please? **Sorted - Hopefully**

    I know it's pretty impossible to tell but....

    I have a 2005 Focus C-Max (56k miles), drove somewhere the other day and after 8 or 9 miles a warning light came on and it said 'Engine Systems Fault' and 'Brake Light Fault'. carried on for a mile or so then spent the day where we were. When I started the car again it started no problem, with no warning light, drove home and again, about a mile away from home it came back on again, same 2 faults. Suffered no loss of power, it drives exactly the same as it always has

    Checked the brake lights and they were all working fine, which is odd. Started it today and the warning light is still on, but started perfectly (as it always has)

    Like I said, I know it's impossible to tell anything, and I have arranged to take it into work tomorrow as the Mechanic department has a computer thing they can connect it to and hopefully diagnose.

    Just a bit worried as we bought the car just over 3 months ago (literally a week or so out of warranty) and really don't want to have to spend a fortune on it, is an engine systems fault likely to be something massive? Ever any occasion when it could be something small?

    It was serviced and went through its MOT with no problems when we bought it.

    Would appreciate any advice (hope) that can be offered.

    25 Comments

    Could be a million things m8
    Some cheap and easy to fix some scarily expensive

    As its still running sweet i would guess it could just be a faulty sensor, but the only way to tell is plug it into the computer..

    Best of luck m8 i've been there and know your pain..lol

    Original Poster

    But doesn't necessarily mean really expensive?

    I've Googled obviously, but most of the problems seem to be struggling to start, losing power, sounding like a bag of nuts etc. Which mine isn't
    Edited by: "sancho1983" 8th Feb 2011

    Sounds very much like mine - I have a 2005, Ford Focus Estate. Our warning light was coming on and off intermittently for a week or 2, went to the garage and they connected it up, said it was some type of filter or something, yet when they checked, it didn't need changing. We've just learnt to ignore it for the last year....

    Original Poster

    tinkerbell28

    Ignore the warranty. If you bought it from a garage you have 6 months … Ignore the warranty. If you bought it from a garage you have 6 months under the SOGA, where the onus of proof is on the garage. Get them to fix it.I've just been though this with an expensive used car, which developed a fault at 3 or so months and needed thousands of pounds worth of work literally, I got the garage to do it under the soga........pm me later if you need info, gtg sort the kids.Oh an if people try to put you off going through the garage, saying you have no rights, it's a used car, sold as seen, blah, blah, blah. Ignore it. It's rubbish.



    Thanks, I bought it trade, not a dealer but a second hand car dealership

    I had probs a few years ago with the engine management system on an old saab, a mechanic stuck his head under the bonnet and disconnected a plug from it and it worked perfectly!! do wonder if there too much technology now.
    Hope you get cheap or free outcome!

    yep. I had the same thing with my focus.. 03 plate. Ford told me some software needed updating on the engine computer?!?! something like that.. anyway 80 quid and 3 months later the light was back. Somtimes it comes on sometimes not. Its always ignored.. Lol
    Although if the light flashes on and off I think thats classed as a serious fault.. but just a solid light.. I'd ignore it.

    Banned

    SOGA covers only defects that were there at the time of sale. It does not cover subsequent faults

    Original Poster

    slamdunkin

    SOGA covers only defects that were there at the time of sale. It does not … SOGA covers only defects that were there at the time of sale. It does not cover subsequent faults



    Proving the fault was there would be difficult to prove I take it?

    Seen as it flew through mot and just been serviced I'm guessing It's 'new'

    My guess (from previous experience) is a faulty sensor.

    Banned

    Your being slightly dramatic Tinks....the OP has a warning light, this doesn't mean he has the same engine problem you had. Are you saying that the OP has to lie when asked if the light was on when he bought the car, because the fact it's come on weeks after he bought it sort of proves that the fault has occured after the car was sold to him.

    Ford engine warning lights come on when a clutch is nearing replacing....do you really think the dealer would be liable after 3 months for such part wearing.

    Banned

    cis_groupie

    My guess (from previous experience) is a faulty sensor.



    Highly likely...but according to tinkabell, OP needs a solicitor to sort the problem out.


    Edited by: "slamdunkin" 8th Feb 2011

    groovygirl36

    I had probs a few years ago with the engine management system on an old … I had probs a few years ago with the engine management system on an old saab, a mechanic stuck his head under the bonnet and disconnected a plug from it and it worked perfectly!! do wonder if there too much technology now.Hope you get cheap or free outcome!



    tell me about it & I work with cars all day, If a car was designed by a mechanic it would be a joy to work on, it'll be pig ugly though !!!

    without looking at it & downloading the diagnostic trouble codes (DTCs), but If your's has a "4 way" brake switch it may be faulty , even though the brake lights are working, it not only does the brake lights to let the person behind you know that you are braking, but it also tells the engine management system/s that the engine is slowing down etc

    Original Poster

    richp

    without looking at it & downloading the diagnostic trouble codes (DTCs), … without looking at it & downloading the diagnostic trouble codes (DTCs), but If your's has a "4 way" brake switch it may be faulty , even though the brake lights are working, it not only does the brake lights to let the person behind you know that you are braking, but it also tells the engine management system/s that the engine is slowing down etc



    Could that give an engine systems fault as well? Expensive?

    sancho1983

    Could that give an engine systems fault as well? Expensive?



    yes it could do, *If* it is the brake light switch, they arnt that expensive, you can replace it yourself, but would need the fault code clearing, but it does really need to be diagnosed to be 100% certain.
    Edited by: "richp" 8th Feb 2011

    Banned

    Head gasket and clutch are not the same inn the soga criteria. clutches are a consumable part that need replacing due to wear, if the clutch goes after a very short time like within a couple of weeks then you may have a case, but 3 months down the line, no chance ...a head gasket is part of the engine and probably blew because the thermostat stopped working properly
    Edited by: "slamdunkin" 8th Feb 2011

    Original Poster

    richp

    yes it could do, *If* it is the brake light switch, they arnt that … yes it could do, *If* it is the brake light switch, they arnt that expensive, you can replace it yourself, but would need the fault code clearing, but it does really need to be diagnosed to be 100% certain.



    Thanks

    So when they run it through the machine tomorrow it will give a code that should 100% tell me what the problem is?

    It is not dark blue and 2.0L Diesel is it? lol?

    Anyways, if not, you are doing the best thing first, get it plugged into a fault code reader then find out what those codes mean, it should be pretty easy to go from there.

    sancho1983

    ThanksSo when they run it through the machine tomorrow it will give a … ThanksSo when they run it through the machine tomorrow it will give a code that should 100% tell me what the problem is?



    yes it will do,it might also be a case of making a note of the fault code, clearing it, then getting you to drive the car for a few days,to see what happens, it may never come on again. Luckily Microsoft dont make cars, otherwise we'd be hitting the restart button every few days !

    HI,

    Read the codes, recorded the codes and clear them.

    Then start the car, go for a test drive and re-read the codes.

    Rick

    Original Poster

    Nope, 1.6, black and petrol! Was that a lemon you have just sold?

    I work at a college and the mechanics department has some readers apparently, so luckily the level 3 students are in tomorrow, obviously under the very watchful eye of the lecturer!

    sancho1983

    Nope, 1.6, black and petrol! Was that a lemon you have just sold? I work … Nope, 1.6, black and petrol! Was that a lemon you have just sold? I work at a college and the mechanics department has some readers apparently, so luckily the level 3 students are in tomorrow, obviously under the very watchful eye of the lecturer!



    No, the mileage and year matched a 2.0D I wrote off, I heard it was being sold on as a Cat D, but had similar issues.

    Tinkerbell, I know how you feel exactly!

    I bought a car in April, 2 months after, major fault with it rendering it useless. It had a full service, MOT & was RAC inspected when I first bought it.
    Dealership didn't want to know, so took them to court and i was agreed that they would fix it at no cost to me. (Still waiting to saee if courts costs will be allowed)
    I only got the car back last week! oO Thats how long it took to get sorted...nightmare but worth it in the end!

    To the OP, I'd take it to the dealership for them to diagnose the faults
    Edited by: "birdyboyuk" 8th Feb 2011

    Original Poster

    Phew, all sorted!

    They ran the diagnostic and it came out as a cruise control problem, which the car doesn't have.

    So they looked at the brakes and noticed that the lights stayed on after the pedal was released, turns out the bracket going to a switch (possibly what Richp was talking about) was a little bent, meaning the light didn't go off, apparently it also has something to do with the cruise control (not switching it off when the brake is applied) hence the engine fault also.

    They fixed the bracket and cleared the code. Hopefully all sorted. No charge also, which was a bonus

    Thanks for all of the comments
    Edited by: "sancho1983" 9th Feb 2011
    Post a comment
    Avatar
    @
      Text
      Top Discussions
      1. Ditched Sky1315
      2. What would be a Mario Kart type game for the PS4?33
      3. Best 40 inch TV for £30056
      4. Biscuit addiction1231

      See more discussions