Minimum IOS version for Apple Watch Series 5

6
Posted 22nd SepEdited by:"Sharpharp"
Anyone know what the minimum IOS version an iPhone must have to pair with the new Apple Watch Series 5 ???
Community Updates
Ask

Groups

6 Comments
iPhone 6s or later, running iOS 13
With watchOS 5, you need to pair it with an iPhone 5s or later with iOS 12 or later—Apple Watch models with cellular require an iPhone 6 or later.
thanks, two replies, two different answers. ios 12 or 13 minimum?
Edited by: "Sharpharp" 22nd Sep
From apples own site in the small print at the bottom:
  • Apple Watch Series 5 and Apple Watch Series 3 require iPhone 6s or later with iOS 13 or later.
Sharpharp22/09/2019 15:46

thanks, two replies, two different answers. ios 12 or 13 minimum?



13
Myriad22/09/2019 15:50

From apples own site in the small print at the bottom:Apple Watch Series 5 …From apples own site in the small print at the bottom:Apple Watch Series 5 and Apple Watch Series 3 require iPhone 6s or later with iOS 13 or later.



thanks, bang there goes the JB
Post a comment
Avatar
@
    Text

    Discussions

    Top Merchants