Modern Warfare 2 game connection

Is anyone else finding that it's taking ages to pair you up with other people when finding a game to enter in?

I've done Hardcore Team Deathmatch, Team Deathmatch and Free For All

31 Comments

happened to me for a while last night, then settled. could just be your connection

Original Poster

ill try re-starting the router

Lol probably your connection

Banned

Same happening for me

But I think it's down the rubbish sagem n router I got with sky

if you find this happens often then you probs need to set up a static ip and open the nessecary ports

What is your NAT type? It says on the screen before you try to join matches

Original Poster

My nat type always says open

How do you set up a static ip

Thanks

if its open then you're ip should be fine its either xbox live or tight internet (capping or just a poor internet provider)

Original Poster

Actually I have just checked and my NAT is at 'Strict'

I never changed the settings, wonder why that happened ??

well you probs need a static then as if it changes you probs have just got lucky one thing to try first though is test xbox live when its done change the ip manually it maybe set like this 192.168.0.3
so manually change it to 192.168.0.6 just change the last digit test again if still no joy put it back to automatic then it should be ok if not you will need to set up a static ip and port forward

Original Poster

Do you not have to then enter a subnet mask and gateway?

no it shouldnt need changing if you need it its probably 255.255.255.0 for subnet mask and your default gateway is the probably 192.168.0.1 if not you can check on your pc by clicking start,all programs then accesories then clicking command prompt then in command prompt type ipconfig\all
then loads of numbers come up just look for the one thats next to default gateway.

Original Poster

When I changed ip address to manual on the Xbox I the when retesting the connection it could even attach to the network

yes thats right cos for that to work the new address you put in would need to be static now set it back to automatic it resets the settings from your xbox to the router and may make it nat open again if it doesnt then you need to do the static ip and port forward.

Original Poster

Ok mate it's still on Strict after all that,

Now how do I set as static ip and port forward?

Sorry bit of a noob here but thanks ever so much for your help
Edited by: "saxo_appeal" 19th Sep 2010

Original Poster

I'm with o2 if that help
Edited by: "saxo_appeal" 19th Sep 2010

its not noob m8 it can be hard you need a pen and paper adn you need to find out your router make and model number to start with then i can try my best to guide you are you set up by ethernet cable?

Original Poster

Set up as wireless with all devices

Router is the Thomson o2 wireless box II

Think it's the only Router o2 send out
Edited by: "saxo_appeal" 19th Sep 2010

did you do this?
start,all programs then accesories then clicking command prompt then in command prompt type ipconfig\all
then loads of numbers come up just look for the one thats next to default gateway.
you need to get the default gateway write it down or remember it then open internet then in the address bar the one right up the top that starts http and delete everything in the address bar and write the default gateway in something like 192.168.0.1 whatever it says in command prompt
if the numbers right then you should be asked for a username and password try admin for both username and password and let me no if it lets you in

ive found this that should guide you straight through i believe this to be your router just take your time and read through every step
portforward.com/eng…htm

Original Poster

Granny and grandads are up to seek little one, will continue later

ok ill check later to see if you need help

Original Poster

Ok I've done the port forwarding but it's still taking ages for the matchmaking to happen and also it still says 'strict'

Original Poster

TCP AND UDP is both at 3075

is that the only ports it tells you to port forward as in no there are more than that and you have changed the static ip you made and put that on the xbox like i showed you earlier.

these are all the ports:
Xbox LIVE requires the following ports to be open: • TCP 80
• UDP 88
• UDP 3074
• TCP 3074
• UDP 53
• TCP 53

Original Poster

Mate thanks for your help it's much appreciated

I called o2 and apparently as I had just had a firmware update all settings were set to default. I had to do a hard reset and the NAT is now Open

Once again thanks for the help and being patient
Edited by: "saxo_appeal" 19th Sep 2010

the good old reset glad you got it working nice of them to tell you though eh.

Original Poster

Yes but it I had to ask to speak to the team manager though, the monkey technical support kept saying they don't support gaming machines!

what chumps well back to pwning for you mate happy days

Original Poster

Yes and thanks again

Can I ask, what does port forwarding do? Just so I have a bit of knowledge from all this
Post a comment
Avatar
@
    Text
    Top Discussions
    1. Magazine competitions - Issue 39 @ tvchoicemagazine.co.uk88
    2. mail on sunday comp - win a £3,000 thomas cook gift e-card44
    3. WIN AN UNFORGETTABLE TRIP TO SAN FRANCISCO11
    4. LG G6 International [email protected] droidauthority22

    See more discussions