Groups

    moto e 2nd gen

    Help please! I've brought my son a pay as you go phone with Vodafone it's a moto e 2nd gen with £10 bundle, I'm trying to activate the sim but it's saying emergency calls only no sim installed even though there is, can any one help as I'm stuck, I know it's not the sim the only thing I can think of is its the the new phone! Any help greatly appreciated many thanks.

    7 Comments

    Have you got the sim in the correct way round and the right socket (not the micro sd),if so and its working in another phone then its 99% its the phone.

    Original Poster

    Yeah sim in the right way & the right slot, I just wondered if there's anything I can do with the phone to enable the sim, but that's anyway.

    I would say get in touch with Vodafone they should be able to sort it for you good luck hope this helps

    Original Poster

    Done that there useless!

    sometimes Sims issued by the network provider need activating / don't work if not activated in first 30 days . this happend to me recently with EE ... they issued me a new SIM & it worked. I can only suggest buying ( or use someone else's) Vodafone sim card ( £1 or less from
    b&m or the pound shop)

    also from wat I remember with the Moto e 2nd generation ... the sim uses a push click system to lock it in place. same to release it ... push the sim card in & it will release. ( hope that makes sense)

    Original Poster

    I've already done that with getting another sim still no joy as for the sim entry/exit slot its clicks in just fine, I'm just wondering if it's a firmware problem! Looks like I'll be taking it back, many thanks
    Post a comment
    Avatar
    @
      Text
      Top Discussions
      1. Iphone 7 - What Case?723
      2. Unexpected house guest query (Ratatouille)68
      3. Ditched Sky1316
      4. Hatchimals on Ebay - are they fake?33

      See more discussions