New firmware updates - Western Digital WD HD TV MEDIA PLAYER

10
Found 5th May 2009
Hi all. Ive been interested in buying one of these badboys for some weeks now. Been put off because it wont play DTS audio from MKV files. But the latest firmware update (Release 1.02.07 on 4/27/2009) claims to have added "more audio formats for MKV container". Has anyone with one of these media players tried this new update? Has it played DTs audio from MKV files?

PS: I've read the deal threads and am aware of free software to convert DTS audio to AC3, but simply dont want the hastle of doing this (Being the lazy git that i am). I also dont want to have to buy an audio receiver or surround sound speakers, i've little room for them in my living room.

Cheers!

10 Comments

Original Poster

Heres the link to the firmware updates release history:
]http//ww…tv/

I've tried their ]knowledge base article, their latest info on supported media files is based on older firware version 1.01.02:

Thnx in advance for any help offered

Slightly off topic here, but:

Whats the diff between DTS 5.1 and AC3 5.1? as ive just started ripping DVDs in Handbrake and it gives me these two 5.1 options. Which one should i encode in?

Can't see anything new regarding audio formats for this release. The release notes state:

· Added subtitle default on or off toggle; previously embedded subtitles were off by default and
external subtitles were on by default.
· Added subtitle thickness selection of “Thick” or “Thin”; this will improve the viewing experience
when the subtitles are viewed against a light colored background
· Added spin down function for USB drives when the device is powered down; previously spin
down only occurred when a drive was ejected

Thanks for the heads up !!! :thumbsup:

Just updated mine !! :-D

Original Poster

Femstar;5122390

Can't see anything new regarding audio formats for this release. The … Can't see anything new regarding audio formats for this release. The release notes state:· Added subtitle default on or off toggle; previously embedded subtitles were off by default andexternal subtitles were on by default.· Added subtitle thickness selection of “Thick” or “Thin”; this will improve the viewing experiencewhen the subtitles are viewed against a light colored background· Added spin down function for USB drives when the device is powered down; previously spindown only occurred when a drive was ejected



Yes ive also read the PDF release notes file, strange theres no mention! but see my post #1, if you follow the link to firmware update page you'll see this:
http://img12.imageshack.us/img12/786/captureosd.jpg



Mecoconuts;5122987

Thanks for the heads up !!! :thumbsup:Just updated mine !! :-D



Maybe you can help me out by testing some MKV's?

Original Poster

Jetpac;5122268

Slightly off topic here, but:Whats the diff between DTS 5.1 and AC3 5.1? … Slightly off topic here, but:Whats the diff between DTS 5.1 and AC3 5.1? as ive just started ripping DVDs in Handbrake and it gives me these two 5.1 options. Which one should i encode in?



As far as i know they're just two different audio codecs for surround sound, each requiring different decoders. AC3 is a dolby digital codec.

If you're playing AC3 from the WD HD TV media player you'll get 2 channel audio only (unless you use the optical output to an audio receiver/surround setup - i think)

* waits to be corrected *

The WD won't play files with 5.1, at least it wouldn't with the old firmware. I'm just downloading the new fw and a 5.1 file. I'll let you know in 20 minutes...

No, still won't play 5.1 without pushing it through an amp first.

It does seem a lot faster with the new firmware moving through the menus, which is nice. . .

Original Poster

steve1221;5124350

No, still won't play 5.1 without pushing it through an amp first..



I guess you're referring to AC3 audio. You happen to try any MKV's with DTS audio?

DTS won't play either, unless you have an amp to decode it. It's passed down the hdmi.

Sorry to digress, but can anyone tell me how to play a subtitle (.sub file) with this Media Player? Having probs getting it to work. Sub file is same name as the AVI video file?
Post a comment
Avatar
@
    Text