Groups

    nintendo dsi help

    just bought the kids 2 of these and i need some info what i need to get it up and running, ie do i need memory cards etc , thanks

    12 Comments

    get acekard2i i think and micro sd memory card

    Dealextreme hadve the ttdsi cards, have ordered a couple and are fine. Get the mirco sd from elsewhere. memorybits are good for this.

    That's presuming you want to run Roms, if you just want to run games then all you need is the games......

    You don't need anything else.

    Original Poster

    i would like to run roms lol i have an 8gb micro sd card with an adapter

    Original Poster

    its a micro sdhc card i have:thumbsup:

    Check which firmware your dsi is on. You need to update the acekard cartridge for dsi games to work, You also need the unofficial software for this Acekard's will not run dsi only dsi lite. If you are on older firmware 1.3 or earlier on Dsi then you can update cartridge thru dsi. If your firmware is 1.4 then you need to update the cartridge thru a ds lite etc first.

    Original Poster

    kboxer;7281846

    Check which firmware your dsi is on. You need to update the acekard … Check which firmware your dsi is on. You need to update the acekard cartridge for dsi games to work, You also need the unofficial software for this Acekard's will not run dsi only dsi lite. If you are on older firmware 1.3 or earlier on Dsi then you can update cartridge thru dsi. If your firmware is 1.4 then you need to update the cartridge thru a ds lite etc first.



    havent a clue mate , just bought 2 lol:thumbsup:

    mark333;7281886

    havent a clue mate , just bought 2 lol:thumbsup:



    PM'd... hope it helps

    kboxer;7281846

    Check which firmware your dsi is on. You need to update the acekard … Check which firmware your dsi is on. You need to update the acekard cartridge for dsi games to work, You also need the unofficial software for this Acekard's will not run dsi only dsi lite. If you are on older firmware 1.3 or earlier on Dsi then you can update cartridge thru dsi. If your firmware is 1.4 then you need to update the cartridge thru a ds lite etc first.



    if my mate gave me a R4i card for the SD with games on, and it works fine, i guess the Dsi has the lastest firmware already on?

    iirc, r4i cards DO work on ds lites! :thumbsup: jjust not the other way ie: you cant use a r4 card on a Dsi

    Original Poster

    is a 8 gb micro sdhc card ok and do i need an adapter for it :thumbsup:

    mark333;7290747

    is a 8 gb micro sdhc card ok and do i need an adapter for it :thumbsup:



    that should be fine, you need a card reader that will read Micro SD cards, but an adaptor is best! :thumbsup:
    Post a comment
    Avatar
    @
      Text
      Top Discussions
      1. Should Cyclists pay road tax and insurance?44
      2. Surprise! The HUKD Summer Flamedeer Hunt 2017 **OFFICIAL THREAD** (trading …5052520
      3. 41% of 40-60 year olds do not go for a brisk walk of >10 minutes A MONTH!1117
      4. word association Game72944199

      See more discussions