No display

24
Found 11th Mar 2017
Hey guys,

I am trying update my graphics card but there is no signal output. When I connect my monitor to my motherboard using vga without graphics card it works perfectly fine. But when I add a graphics card none of the outputs give a signal. Even when with graphics card, and I plug vga into motherboard, there is no signal. Can you guys please help me. Thank You. The bios is up to date.

EDIT: Found out the HDMI was faulty. Sorry for the incovenience, got a new hdmi cable. Thanks for your contributions guys.
Community Updates
Ask
24 Comments
Grfx Setting in bios could be set to just use on board grfx?
Not enough power to grfx card.
How do I change it?
Have you tried taking card out and refitting?

Does it show up in windows device manager?
I have refitted. Also I can't get into windows when the graphics card is plugged in
And guys I hear the standard 1 beep which signifies everything is working so I don't know why this happens
Not enough power to card
What graphics card? What motherboard? What PSU? How is everything setup?

I would suggest making absolutely sure the card is seated properly (there should be a lever lock on most motherboards that will click into place at one end, but make sure it is also all the way in at the other end), that it is connected to the PSU and receiving enough power (some cards need two cables) and that your BIOS settings are telling the motherboard to use the dedicated graphics (and which slot to use) if that's an option.
ItI think it's 500w psu and also the fans on grfx card spin then stop but I was told this was a feature of the gtx 1050ti card if it doesn't require that much load. I do hear a click. The grfx card is in place. it requires a 6 pin connector I have done that still nothing. How do I go about telling my motherboard graphics in bios?

It is a gigabyte h110m-s2h mobo
Gigabyte 1050ti OC edition
500w psu

Edited by: "DawDaws12" 11th Mar 2017
DawDaws12

ItI think it's 700w psu and also the fans on grfx card spin then stop but … ItI think it's 700w psu and also the fans on grfx card spin then stop but I was told this was a feature of the gtx 1050ti card if it doesn't require that much load. I do hear a click. The grfx card is in place. it requires a 6 pin connector I have done that still nothing. How do I go about telling my motherboard graphics in bios?It is a gigabyte h110m-s2h moboGigabyte 1050ti OC edition700w psu


Okay, there should be no compatibility issues between the mobo and graphics card there, and a 700w PSU should be enough to cover them.

Looking at your mobo's manual, there's a BIOS setting called 'Initial Display Output' (second option down, under 'Peripherals'). If you're getting a display from your onboard graphics then you probably need to change that from 'IGFX' (integrated graphics) to 'PCIe 1 Slot' (where your 1050Ti is).
Edited by: "reddragon105" 11th Mar 2017
Ok i will do that
Op, your updating graphics card? Is this card brand new or second hand? Do you know it actually works? The card may be faulty, or the motherboard,?
Most realistic to be bios settings as stated above
not enough power?
novatech.co.uk/pro…tml -PSU link

Full spec:
Gigabyte H110M-S2H
16 GB DDR4 RAM
i3-7100U
500w psu
The PSU appears to have a 24 pin (20+4) ATX power (make sure the full 24 is used).
But only a 4 pin EPS - not sure if this results in a power limitation. it is also a split 12V with 17A on 12V1 & 12V2 - this may be causing a power distribution issue if everything falls on 12V1.
12V2 often powers the PCI-E connector, but PCI-E to EPS are rare and expensive... only found 1 or 2 and the price is shocking.

If you try the 4 pin + molex. if there is more than one chain of molex, try each chain, one may be on 12V1 and the other may be on 12V2.

Using a 4 pin + molex to 8 pin adapter may improve the power distribution.
are you certain?
DawDaws12

https://www.novatech.co.uk/products/components/powersupplies/451wto650w/nov-psu500.html -PSU linkFull spec:Gigabyte H110M-S2H16 GB DDR4 RAMi3-7100U500w psu


I'd check your home insurance for fire damage oO
What made you choose that PSU besides it extremely cheap price, it's an generic built PSU that could of been manufactured anywhere by anyone. I'd recommend trying the card in another PC and trying a different PSU, I wouldn't believe any of the specs on that PSU.
Make sure the power cable is seated in your graphics card properly, if re-seating doesn't work.

It's unlikely to be the following but:
Check power options in bios make sure it's not limiting anything, check your bios for a fast boot option, disable fast boot. Disable launch CSM (comparability support module),


Then in windows in display settings, power and sleep, additional power settings, make sure you have "preferred plans" set to high performance then click change plan settings next to high performance, advance power settings, PCI Express, link power management is set to maximum power settings.
Also looking at your manual under chooser you have an option for "internal graphics", make sure it's set to auto.
If the psu is the problem can you guys recommend me one?
catbeans

Also looking at your manual under chooser you have an option for … Also looking at your manual under chooser you have an option for "internal graphics", make sure it's set to auto.


I would actually suggest setting it to off for troubleshooting purposes, to try to force the mobo to use the dedicated graphics - you don't want it to auto switch to the internal graphics over the PCI card for any reason.

DawDaws12

If the psu is the problem can you guys recommend me one?


Yeah, bit concerned about the PSU now. 500w should still be enough, but it's only £20 - cheap power supplies often struggle to provide consistent current draw. I would definitely recommend spending more than £20 on a PSU if you're building a mid- to high-spec system, it's certainly cost effective in the long run - after having a cheap PSU go bang and pour out smoke on me, I bought a Coolermaster 1000w with a 10 year guarantee for £100 and it's still going strong 6-7 years and 3 PC builds later. That might sound like overkill, but do test your system with a better PSU if you can. Use a calculator like this one to enter all of your components and get the wattage value you should be going for, then maybe times it by 150% to be on the safe side, or if you'll be overclocking.

Also, out of interest, what other components do you have? CPU, RAM, HDDs, etc.?
I have a i3 7100
500GB HDD
16GB DDR4 RAM


EDIT: I done the wattage test and it recommends me a 500w psu (without overclocking)
Edited by: "DawDaws12" 12th Mar 2017
You've probably checked this but How are you connecting the gpu to the monitor? some monitors require you to switch source.
I am connecting via HDMI
Post a comment
Avatar
@
    Text

    Discussions

    Top Merchants