Nokia 8 owners

14
Found 9th Jan
Beginning to wish I never bought this phone tbh.
Since the most recent update, there is no vibration feedback for any of the navigation keys, finger scanner/home button or the keyboard. Second of all my notifications for text messages seem to be on constant silent regardless of what I have my prefer sets to. I like sound and curate notifications for most things and it seems to work fine for incoming calls but I have the same settings applied for texts (or to have a sound and vibration) and yet it is just silent.

Can anyone advise whether these are bugs or whether my Nokia 8 is just being sucky.
Community Updates
AskElectronics
14 Comments
I had an N96 when it first came out. So excited to get it. Then the sound went 'weird'. No incoming calls rang, no message notification. Factory reset, reloaded ask the software in the shop - they suits it. Still no good. Swapped it for an htc.
Your problems seem strange. I have a Nokia 8 and I'm definitely not having these problems, and I'm on the latest version of firmware.
Edited by: "mshaw213" 9th Jan
mshaw21339 m ago

Your problems seem strange. I have a Nokia 8 and I'm definitely not having …Your problems seem strange. I have a Nokia 8 and I'm definitely not having these problems, and I'm on the latest version of firmware.


That's not reassuring at all I'll double check the exact version I'm running tonight but it should be the most recent official update L. These problems did not exist before. I've contacted Nokia directly but don't expect a reply. Given that vibrate and sound seem tow role for incoming calls it cannot be an actual issue with the sound or vibrate function themselves
little_green34 m ago

That's not reassuring at all I'll double check the exact version I'm …That's not reassuring at all I'll double check the exact version I'm running tonight but it should be the most recent official update L. These problems did not exist before. I've contacted Nokia directly but don't expect a reply. Given that vibrate and sound seem tow role for incoming calls it cannot be an actual issue with the sound or vibrate function themselves


have you tried the very first thing that usually fixes most issues? its called factory reset
You haven't enabled any social sounds setting?
mrty1 h, 30 m ago

You haven't enabled any social sounds setting?


Not that I'm aware unless it's something that could happen accidentally
little_green1 h, 25 m ago

Not that I'm aware unless it's something that could happen accidentally


The N96 had some sorry of surround sound setting, this was causing the error. Some ringtones worked with it and others didn't, as I found out later.
Id rather have that then my WiFi cuting in and out on my Nokia hoovering up my data contacted Nokia done all there steps and it still doesn't seem to work right
mrty10 h, 16 m ago

I had an N96 when it first came out. So excited to get it. Then the sound …I had an N96 when it first came out. So excited to get it. Then the sound went 'weird'. No incoming calls rang, no message notification. Factory reset, reloaded ask the software in the shop - they suits it. Still no good. Swapped it for an htc.


i also had the same problem with the n96 and the screen would freeze so you couldnt answer calls
jjmmww19th Jan

Id rather have that then my WiFi cuting in and out on my Nokia hoovering …Id rather have that then my WiFi cuting in and out on my Nokia hoovering up my data contacted Nokia done all there steps and it still doesn't seem to work right


I suspect you mean your home wifi network, it will almost certainly be because you have your router broadcasting both 2.4 and 5ghz on the same "wifiid" and whilst it can connect to say 2.4 it can't connect properly to 5 and so drops off.

you on bt perchance for broadband at home? or indeed virgin ?
pontprennau48 m ago

I suspect you mean your home wifi network, it will almost certainly be …I suspect you mean your home wifi network, it will almost certainly be because you have your router broadcasting both 2.4 and 5ghz on the same "wifiid" and whilst it can connect to say 2.4 it can't connect properly to 5 and so drops off. you on bt perchance for broadband at home? or indeed virgin ?

With bt
jjmmww11 h, 5 m ago

With bt


it's due to the 2.4 / 5 ghz sharing the same id, so when you connect to one it'll be fine. with the other it will drop off randomly.

it's not asking you to "login" to the wifi again is it when it drops off? as this is a different issue
pontprennau2 h, 47 m ago

it's due to the 2.4 / 5 ghz sharing the same id, so when you connect to …it's due to the 2.4 / 5 ghz sharing the same id, so when you connect to one it'll be fine. with the other it will drop off randomly.it's not asking you to "login" to the wifi again is it when it drops off? as this is a different issue


No just drops down and says no internet connection then have to turn it on and off or airplane mode it
33368153-07nvn.jpg
You should have bought an iphone
Post a comment
Avatar
@
    Text

    Top Discussions

    Top Discussions

    Top Merchants