Found 26th Dec 2014
Would appreciate any help or wild guesses!!

Installed new card today and at same time updated drivers. One Nvidia card for another.

I run my pc through a tv and had no issues before, but now get locked with dodgy resolution 1560x when trying to run most games. So they either half appear on screen or squashed out of all proportion! No option for 1920x1080
Some games like far cry just send the TV into a meltdown flicking between aspect settings on a black screen.
Tried clean install and rolling back to previous driver and that resolved a couple of games, but also tried switching gfx cards back and still same issue!

Anyone have any ideas that don't involve os reinstall!!!?!

Thanks!

  1. Ask
  2. NVIDIA
Groups
  1. Ask
  2. NVIDIA
13 Comments

did you get the drivers from windows update or nvidia? I've just had to resolve issues after an update to 8.1 on a laptop. Get the relevant update tool from Nvidia before going further.

Original Poster

Yep tried the drivers direct from nvidia. (Used the nvidia control panel first but thought that may be the issue)

Try the tv/monitor settings. Sounds daft but... my son connected his xbox one to a tv he had never really used before. At first it was fine then after installing a game the resolution started to mess up. It was the screen settings, not the console. Good luck.

Original Poster

tried that also but some games work and I haven't changed anything on the tv. Ryse now only works if I turn off native full screen in game settings but still won't run 1080.

I used to have a issue on amd (radeon) that would restrict my resolution. It would lock my res when on the TV, the ccc (catalyst program) had an option to force the resolution to what I wanted. Solved the issue for me, thought I didn't have any flickering issues. Could be a refresh rate not being matched?

Is there anything like that on nvidia program?

One thing to look out for when you install graphics card drivers always make sure you tick the box for fresh install or remove old drivers ran into loads of problems in our 2 gaming computers ticked the box for fresh install with new drivers and hey presto worked fine

Original Poster

Removed all old drivers first in safe mode so that shouldn't be an issue.
Tried all scaling options in the nvidia control panel to no avail.

Best use DDU wagnardmobile.com/DDU/
It asks you to boot into safe mode and does it automatically. Run that and clear all your GPU first, reboot in to normal mode and install the new drivers.
Edited by: "rev6" 26th Dec 2014

Original Poster

Comment

rev6

Best use DDU http://www.wagnardmobile.com/DDU/It asks you to boot into … Best use DDU http://www.wagnardmobile.com/DDU/It asks you to boot into safe mode and does it automatically. Run that and clear all your GPU first, reboot in to normal mode and install the new drivers.



Cheers rev, Yep that was the process I went through. Just doesn't seem to like talking to my to anymore can't seem to detect the resolution when starting games. So either messes it up and crashes, runs in wrong res, or allows me on a few games to override once it starts (providing I can see the option menu!!!!)

check the hdmi lead. also check the edid for corruption.

Original Poster

Swapped the tv and the lead with the same results. Far cry is worst effected as both TVs seem to rapidly switch modes for around mins as they fight with it!!

can you swap pcie socket and psu leads ? Sounds like some sort of conflict. does this only happen when entering directx3d and if so is this dx9 or dx11 ?

Original Poster

Gone for the fresh os install let's see if that fixes it.....
Post a comment
Avatar
@
    Text
    Top Discussions
    1. Just heard this...2 ★★★★★★★★★★★★★★ congrats to all on 392k ★★★★★★★★★★★★★★7769298
    2. Coming up to bonfire night ...2131
    3. £6 Promo Credit with £30 Gift Card Purchase @ Amazon33
    4. The never ending counting with pictures thread !4604801

    See more discussions