PC not powering up help/suggestions

10
Found 23rd Feb 2011
A friends PC has stopped working.
Opened the case, PSU fan and CPU fans come on 10sec max then off.

Disconnected each power cable until found the 4pin 12v cable seems to be related to the issue, the power stayed on/fans running with this being the only change to the system (removed). No feed to monitor.

Apparently it's for the CPU, so either it's the CPU is dead or the Mobo?

Anyone know of this/ helpful advice or suggestions?
Cheers.

P.s. Off to bed soon but will be online regularly tomorrow.

10 Comments

Could be a few things
Your power supply. As they get older PSU tend to give a lower output and your friends might just have reached tipping point.
Could be a short on the board check there are no bent pins, bits of solder or screws on the motherboard.
Could also be a faulty cpu fan tripping out the cpu thermal protection in bios. If it is the latter resetting the bios could fix it.
Your power button could be sticking causing a system shutdown.

Here is a flowchart to check power supply problems

Edited by: "trog0" 24th Feb 2011

Original Poster

Cheers for the help,

trog0

Could be a few things Your power supply. As they get older PSU tend to … Could be a few things Your power supply. As they get older PSU tend to give a lower output and your friends might just have reached tipping point.


^ I'll see if my PSU is compatible and see if that's it.


trog0

Could be a short on the board check there are no bent pins, bits of … Could be a short on the board check there are no bent pins, bits of solder or screws on the motherboard.


First thing I'll do when I get my hands on it again later.


trog0

Could also be a faulty cpu fan tripping out the cpu thermal protection in … Could also be a faulty cpu fan tripping out the cpu thermal protection in bios. If it is the latter resetting the bios could fix it.


I'll try this after checking for short circuits.


trog0

Your power button could be sticking causing a system shutdown.


Cool, will remove casing etc around there and see how it looks visibly anyway.


trog0

Here is a flowchart to check power supply problems



Hoping it's a relatively straight forward find, I'm at the limit of my knowledge.
Just hoping to keep my mate from being fleeced at a shop But being careful not to cause further issues.

Very much appreciate the advice/suggestions,
Cheers

trog0

Could be a few things Your power supply. As they get older PSU tend to … Could be a few things Your power supply. As they get older PSU tend to give a lower output and your friends might just have reached tipping point.

trog0

Could be a short on the board check there are no bent pins, bits of … Could be a short on the board check there are no bent pins, bits of solder or screws on the motherboard.

trog0

Could also be a faulty cpu fan tripping out the cpu thermal protection … Could also be a faulty cpu fan tripping out the cpu thermal protection in bios. If it is the latter resetting the bios could fix it.

trog0

Your power button could be sticking causing a system shutdown.

trog0

Here is a flowchart to check power supply problems



It's not really being fleeced when someone sells you an hour or so of their time, in which they utilize years of experience and expertise to revive the dead system. Knowledge and skill isn't free to acquire.

Original Poster

dxx

It's not really being fleeced when someone sells you an hour or so of … It's not really being fleeced when someone sells you an hour or so of their time, in which they utilize years of experience and expertise to revive the dead system. Knowledge and skill isn't free to acquire.



Very true, just don't know anyone near here I would trust to charge for their time and any parts that actually need replacing.
Previous bad experience, told a friend who lived way outta town to pop into their local pc guy when they needed to replace the cmos battery, even told them that was all they required.
Guy tutted, leave it with me, I'll have to order a part, big job £90 - £110!
Was easier for me to order the battery, cost less than £10 and they went to the trouble of driving to me, so I could swap battery in 5mins.
If I knew someone local who is reliable I'd happily send them there as soon as it goes beyond my knowledge.

vinnyabdn

Very true, just don't know anyone near here I would trust to charge for … Very true, just don't know anyone near here I would trust to charge for their time and any parts that actually need replacing.Previous bad experience, told a friend who lived way outta town to pop into their local pc guy when they needed to replace the cmos battery, even told them that was all they required.Guy tutted, leave it with me, I'll have to order a part, big job £90 - £110!Was easier for me to order the battery, cost less than £10 and they went to the trouble of driving to me, so I could swap battery in 5mins.If I knew someone local who is reliable I'd happily send them there as soon as it goes beyond my knowledge.



Talking of replacing the battery that's probably the easiest way to reset your bios. unplug all the power and remove the battery for ten seconds.

From another thread I posted in, so I apologise for the copy/paste but it may help you out.

If all that is true, the last thing to try is to disconnect the Power … If all that is true, the last thing to try is to disconnect the Power Supply from the motherboard and the mains. So take the kettle plug out of the back, switch it off if there is an on/off switch (don't touch any voltage switches if the power supply has them). Remove the 4/8pin cable and the 20/24 pin cable from the motherboard which come from the power supply. Take the CMOS battery out (click <<< if you don't know what I mean) . Leave the system like this for an hour or so, then reconnect the cables to the motherboard and put the battery back in, hook up the Power Supply to the mains, turn it on, then power up.



This is generally what I do (or swap and change the PSU completely) when I have the same sort of issue you are talking about (sounds liked a tripped power supply). It would be a good idea to disconnect power from everything really, leave the power supply alone for a while, then only connect up what you need for the PC to post (the motherboard and graphics card power connectors). Also another thing I sometimes do is remove the memory, try to get some beeps, then place one stick of RAM in, see what happens, move it around, see if I can get a post. Sometimes mad shizzle happens and it just takes a fair bit of troubleshooting to sort it out. Just make sure whenever you are changing hardware (like putting in and pulling out memory), that the PSU is disconnected from the mains. Sometimes forgetting to do this can trip the motherboard/psu and then you are back to square one.

Good luck!

-edit: Just noticed tr0gs comment which I forgot about. The motherboard standoffs and screws can sometimes cause issues, usually when they are over tightened. You could set up the system outside of the case which I also do quite often, just be very careful where you are setting it up outside of the case though as you can easily cause more issues for yourself.

http://www.legitreviews.com/images/reviews/676/test_system.jpg
Edited by: "PhearFactor" 25th Feb 2011

Original Poster

Cheers trog0 and PhearFactor, not had a chance to get back to it yet, on night shift Sat + Sunday so might get a chance at some point during the night
Will update if I get anywhere or end up passing it on.

Edited by: "vinnyabdn" 25th Feb 2011

Lift the processor, turn on, turn off, put processor back. Worth a try. In all the years I was fixing PC's sometimes the most random of things corrected the problem!!

Original Poster

aircanman

Lift the processor, turn on, turn off, put processor back. Worth a try. … Lift the processor, turn on, turn off, put processor back. Worth a try. In all the years I was fixing PC's sometimes the most random of things corrected the problem!!


It will be added to the list of things I'll try.
Cheers

Original Poster

Hi Guys,
Tried all the above, but it was still the same.
Got back to my mate and he wanted to replace mobo and cpu so went for the cheap bundle from misco. And that was that problem sorted.
Then Vista wouldn't load!
Tried all sorts of boot repair attempts with no effect.

So ended up using parted magic to recover personal stuff before reinstalling vista.

Cheers for all advice.

Vinny
Post a comment
Avatar
@
    Text
    Top Discussions
    1. Quidco Snow me the money Competition821056
    2. Magazine competitions - Issue 46 @ tvchoicemagazine.co.uk1313
    3. Enter to win an iPhone X Anker competition33
    4. Win £500 worth of goods from RAF Museum's shop66

    See more discussions