Groups

    PC won't power on - think it's the motherboard - oh heck!

    Green flashing light at the back where the power supply unit is. Disconnected the cable to the motherboard as suggested in forums and now no green flashing light. Do you think it is the motherboard? PC was working fine before - no hint of an impending problem. Anything I can try before I get the motherboard replaced?

    Also, I know it's a HP pavillion about 5 years old but can't find the model number on the PC!

    6 Comments

    Are you sure the green flashing light is not the ethernet / network light. Some PCs have a flashing green light when it is connected to the internet.

    Banned

    What happens when you switch it on? Are there any beeps as all?

    Seeing as it's 5 years old, it might be easier to buy a new PC rather than go to the trouble of fitting a new MB, especially if you have never done that before

    Banned

    I take it you have tried the obvious (i.e removed the power cable completely from the psu and wait 30 secs).

    Could be the PSU but hard to tell as you havent stated how it started to fail.

    Original Poster

    Thanks for all your replies.

    Sorry - more info. The green light is usually lit not flashing and located just under where the power cable plugs in. Now, the unit will not turn on and the light flashing green and making a tick noise - tic, tic, tic........ I followed the troubleshooting on HP site which said remove power cable, press power switch etc. It then said follow the lead from the switch to the motherboard and reseat it - did that but the same. Then said remove the 24 pin from the motherboard - did that and the green light stays lit with no tic noise.

    I kind of think a new base untit may be best but will I be able to recover the stuff on my hard drive?

    Will post photo when i get a chance.

    Original Poster

    csiman;7482555

    I take it you have tried the obvious (i.e removed the power cable … I take it you have tried the obvious (i.e removed the power cable completely from the psu and wait 30 secs).Could be the PSU but hard to tell as you havent stated how it started to fail.



    Yep, removed the cable and everything connected to PC. Was working yesterday fine with no indication there was a problem. Only thing I did before I realised it was not working was take out the power lead as I wanted to use it for an old base unit I had. I tipped the not working one forward slightly to remove the cable (something I have done before) then when I tried to turn it on later - nothing. No boot up, fan sound - dead - just the blinking green light with the tic noise.

    Original Poster

    dcx_badass;7483085

    Data is easy to get off if the HDD is fine, sounds like a PSU problem to … Data is easy to get off if the HDD is fine, sounds like a PSU problem to me if it's ticking.



    Well that's what I thought but when I disconnected it from the motherboard it turned on.

    Can I get the data from the hdd to a laptop. How can I do that?

    Thanks for the replies everyone.
    Post a comment
    Avatar
    @
      Text
      Top Discussions
      1. ❅☁☁❅ I want☼to talk☼about the☔WEATHER☔no politics☃no religion❅☁☁❅18846221
      2. 75% off Sky TV for existing customers. Only works when you call the specifi…17416144
      3. I've got 2 for 1 codes to use at Thorpe Park/Sea Life, Yeoken vouchers, The…34
      4. Weekly game codes giveaway 1831227

      See more discussions