Expired

Problem with PS3 dualshock controller

SuperEd 4 replies
Found 17th Apr 2011
Right tried to play my PS3 last night but when i pressed the PS button it didnt come on,so plugged in via usb and all working fine and thought the battery was low/dead.

Left to charge for 30 mins and then unplugged the controller but 2 lights flashed once and went off and now wont work unless its plugged in all the time ?

Any ideas ? if tried resetting the controller but still the same issue ?

TIA

4 Comments

try reconnecting it thru the ps3 menu

Dead battery inside controller? Battery may not be holding its charge no more meaning you have to always have it plugged in or buy a new battery for the pad

Maybe the battery has died, this happened to one of my old non-dual shock ones (the ones that came out @ PS3 launch)

Why oh why could they not make the battery packs replaceable like they did with the Xbox 360 ones???

Original Poster SuperEd

thanks for all of the replies - think ive managed to sort it . Tried numerous USB cables but then decided to plug into the PC,then i put it back in the PS3 and it seems to be charging
Post a comment
Avatar
@
    Text
    Top Discussions
    1. Without giving away your age, name three things that remind you of when you…3973
    2. Limited quantities of STRAFE® and SHADOW WARRIOR 2 for sale @ Special Reser…46
    3. Smacking children is to be banned in Scotland3275
    4. *** Weekly game codes giveaway 192 ***215

    See more discussions