Problems with Stihl FS55 Strimmer.

6
Found 20th Jun 2015
Can anyone give me some advice as to what the problem may be before I start tinkering.

The symptoms are this: Its starts and runs fine when the choke is on, but as soon as I turn off the choke it dies and it will not start with the choke off even once its warm and been running for a little while.

I was thinking about cleaning the carb and getting new gaskets ect... or could it be the mixture screws need adjusting?

Thanks in advance, any useful information would be grateful.
Community Updates
AskMovie & SeriesStrimmer
6 Comments
Try adjusting the mixture or tickover screw to increase the revs a little. Before you start taking the carb apart.
Sprograt

Try adjusting the mixture or tickover screw to increase the revs a … Try adjusting the mixture or tickover screw to increase the revs a little. Before you start taking the carb apart.



Okay cheers, I've give that ago tomorrow and see how I get on.
joshp

Okay cheers, I've give that ago tomorrow and see how I get on.



Also make sure the air filter isn't blocked as this could effect the running of the engine. This webpage could help you. manualslib.com/man…=34
Edited by: "Sprograt" 20th Jun 2015
Sprograt

Also make sure the air filter isn't blocked as this could effect the … Also make sure the air filter isn't blocked as this could effect the running of the engine. This webpage could help you. http://www.manualslib.com/manual/165810/Stihl-Fs-55.html?page=34#manual



Excellent, thanks again. I'll take a look at that.
If this happened on a older model car I would have said the idle jet is blocked ,but on a strimmer ....................not sure if it has a jet .I would say it had something to do with the carb though. Take it off ,clean it out , then try it .
ricko

If this happened on a older model car I would have said the idle jet is … If this happened on a older model car I would have said the idle jet is blocked ,but on a strimmer ....................not sure if it has a jet .I would say it had something to do with the carb though. Take it off ,clean it out , then try it .


As far as I know they have a main and an idle jet, and like you I'm guessing one of them is blocked.
Post a comment
Avatar
@
    Text

    Top Discussions

    Top Discussions

    Top Merchants