PSP Firmware advice

Been ages since ive been on the PSP scene. Struggling to play new .iso's cos im getting the unable to read game error messge. Old .iso's still play fine.

Im running firmware 3.40 oe-a. i suspect i need to upgrade this to a new FW but which one. PSP model is a 1003

Not after a step by step guide just some advice to head in the right direction.

4 Comments

I'm running Gen-B on my son's, it runs pretty much everything.

The latest iso's seem to need to be patched.

5.50 Gen D3 is the latest but can be a bit buggy, it should however play pretty much anything.

Original Poster

hornblowerracing;7632104

I'm running Gen-B on my son's, it runs pretty much everything.The latest … I'm running Gen-B on my son's, it runs pretty much everything.The latest iso's seem to need to be patched.



yeh i read that aswell, just a bit confusing. did u upgrade from same FW as what i have?

lanc_red;7632117

yeh i read that aswell, just a bit confusing. did u upgrade from same FW … yeh i read that aswell, just a bit confusing. did u upgrade from same FW as what i have?



No, we were running M33-6.
Post a comment
Avatar
@
    Text
    Top Discussions
    1. Sad news about Barcelona1972
    2. ❅☁☁❅ I want☼to talk☼about the☔WEATHER☔no politics☃no religion❅☁☁❅18846124
    3. How much would you pay for this chair?1113
    4. I banned myself from HUKD for 3m, I saved so much money!2540

    See more discussions