Question for car mechanic about oil filter.

3
Found 2nd Nov 2017
just changed oil and oil filter in Mazda 2 diesel for 1st time. same engine as fiesta 1.4 tdci. All went to plan, but when I removed the oil filter cap I am sure that there was no old o-ring fitted on the cap. The new filter came with a new o-ring in the box, but when I tried to tighten cap with o-ring in place it was impossible to do without the o-ring coming out of the groove. The new o ring seemed a bit too big for fitting into the groove also. My question is ...as the car didn't appear to have one fitted before I should be ok to tighten up with one missing? I ran the car engine for 5 mins with no leaks.
Community Updates
Ask
3 Comments
It will leak with no seal, I nipped an oil seal on a polo once and it came back with a leak. You sure it hasn’t got a seal already? Not 100 percent but I think the seal is on thelast thread rather than all the way at the bottom of the housing if that makes sense. Also make sure the filter located properly as they only fit one way and will cause oil pressure and engine problems if not fitted right
A word of warning... I changed the filter on my car. Took the old one off, dropped it in the old oil tank and replaced it with the new one complete with o ring seal.
Refilled the oil and drove it away...leaving oil all over the road. Stopped the car. Scratched my head for half an hour. Took the new filter off and compared it with the old one - no seal.
Found the old seal stuck to the car. I'd actually put 2 seals on, so they didn't seal. If I were you I'd check that you haven't done the same as me. If you have it may be sealed for now...but when it gets hot, maybe not.
Edited by: "mrty" 2nd Nov 2017
mrty2nd Nov

A word of warning... I changed the filter on my car. Took the old one off, …A word of warning... I changed the filter on my car. Took the old one off, dropped it in the old oil tank and replaced it with the new one complete with o ring seal.Refilled the oil and drove it away...leaving oil all over the road. Stopped the car. Scratched my head for half an hour. Took the new filter off and compared it with the old one - no seal. Found the old seal stuck to the car. I'd actually put 2 seals on, so they didn't seal. If I were you I'd check that you haven't done the same as me. If you have it may be sealed for now...but when it gets hot, maybe not.

Yes I had put 2 seals on, thanks for the pointer
Post a comment
Avatar
@
    Text

    Top Discussions

    Top Discussions

    Top Merchants