Slow WiFi on Android pie with Bluetooth

8
Posted 22nd Mar 2019
Hi,
I upgraded my Moto G6 to android pie. The WiFi aired is shockingly low (500kbps) now unless I deactivate Bluetooth. I had the same issue with a Xiaomi Mi A2 lite. I returned the latter phone. Anyone know how to solve it without having to turn off Bluetooth? Sims people are saying to set the WiFi to a 5Ghz frequency to avoid clashing with the Bluetooth frequency. Maybe @Mrswitch knows something?
Community Updates
Ask
8 Comments
I'd have said exactly that, set it to 5ghz.

But to be honest failing that,, I've never really experienced the same. Sorry buddy
Edited by: "MrSwitch" 22nd Mar 2019
MrSwitch22/03/2019 07:01

I'd have said exactly that, set it to 5ghz.But to be honest failing that,, …I'd have said exactly that, set it to 5ghz.But to be honest failing that,, I've never really experienced the same. Sorry buddy


How would you set it to 5 gigahertz
salahwrexham4 m ago

How would you set it to 5 gigahertz


Deep in the advanced settings mate, change frequency.
I just found it's automatic on the moto G6 if you have a 5ghz available. It works well in work but I only have 2.4ghz at home...
salahwrexham22/03/2019 07:17

How would you set it to 5 gigahertz


Google..... how to change WiFi frequency on *router model*
thats if it’s a 5ghz compatible router though
salahwrexham1 h, 8 m ago

I just found it's automatic on the moto G6 if you have a 5ghz available. …I just found it's automatic on the moto G6 if you have a 5ghz available. It works well in work but I only have 2.4ghz at home...


My router has 2.4 and 5ghz you just select which one when connecting to WiFi some routers don't support it
Edited by: "_Tris_" 22nd Mar 2019
howarth37 h, 24 m ago

Google..... how to change WiFi frequency on *router model* thats if it’s a …Google..... how to change WiFi frequency on *router model* thats if it’s a 5ghz compatible router though


Sorry... Sometimes when I write stuff I leave about 90% of the information out of it I have a Sky router and I don't think it supports 5ghz. I have researched it and only the new Q model supports 5ghz. Is there anyway to force the black sky routers to transmit at 5ghz or is the technology not present?
Hi all,

I found a solution on the internet and it seems to cure the issue. WiFi is a lot faster now even with Bluetooth on:
Settings app, then hit Wi-Fi > Wi-Fi Preferences > Advanced, then change Network Rating Provider from Google to None.
Post a comment
Avatar
@
    Text

    Discussions

    Top Merchants