Groups

    SM T310 touch not working

    Person left me a Samsung SM T310 tab was working fine last week the man said.He thinks it got an update and after that the touch is not working. I opened the back and check all connection, they where all ok. I tried a factory reset but still nothing, i used Odin software to flash the latest firmare on it and it installed ok but still the touch is not working, Any ideas,would and earlier rom do the job???, Also just to confirm the tablet did not get any damage,not dropped knocked or anything

    5 Comments

    Check the ribbon cable from the digitiser is seated correctly, I seem to remember reports of it coming loose over time due to internal heat. Holding the tablet portrait screen forward the connector is in the top right hand corner area near the front camera.

    If the digitiser is the culprit and not just a loose connection you can pick them up for around £8-£10. Worth doing as these are very good tablets.

    Edited by: "Argoj" 7th Oct 2016

    boot the device in safe mode ( Make sure your device is turned off.
    Press and hold the Power key to boot up your device.
    After the start-up animation begins to display, press and hold the Volume down key.)

    this also happened to me so this should most likely work

    Original Poster

    nope none work, safe mode still not working check cable everything but nothing, think i will just have to replace the touch, I do not think he does not wants to spend much so may end up giving him a couple of pounds for it and fix for myself

    If you need it there is a good how to video link below, about half way down the page.

    ifixit.com/Gui…024
    Edited by: "Argoj" 7th Oct 2016

    Original Poster

    THANKS
    Post a comment
    Avatar
    @
      Text
      Top Discussions
      1. Customs charged too much for a little item!66
      2. Xiaomi redmi note 4 firmware34
      3. Multi fuel stove deals11
      4. Memory foam mattress topper56

      See more discussions