Expired

[Solved] How to use openreach modem with Asus RT-AC68U?

26
Found 21st Jun 2017
I have been trying to use my own router with sky broadband (adsl) for the 5hours and still cant seem to get it to work. I followed few guides including the one here avforums.com/thr…17/ but still cant seem to get it to work. Can someone help me out please

EDIT:

What I'm trying to achieve?

I have a standard sky broadband (not fibre) and wish to use my own router (current one sucks). The problem is that the router provided by sky does not have any option for "modem only" mode. I bought the openreach modem thinking it will work. Now that I just found out that the openreach modem will only work for fibre broadband I don't have a clue what to do next. I just the want asus router to do most of the work so i can get better and more stable connection
Community Updates
26 Comments
Simplistically: disable DHCP on the Sky router, enable DHCP on the Asus, use a LAN cable to connect a yellow port on the Sky router to the blue port on the Asus. Assuming the telephone / modem cable is still connected to the Sky router, you should then be good to go. If you have been playing with either device for a while, it may be worth performing a hard reset on both, then set the DHCP on both.
Original Poster
AndyRoyd

Simplistically: disable DHCP on the Sky router, enable DHCP on the Asus, … Simplistically: disable DHCP on the Sky router, enable DHCP on the Asus, use a LAN cable to connect a yellow port on the Sky router to the blue port on the Asus. Assuming the telephone / modem cable is still connected to the Sky router, you should then be good to go. If you have been playing with either device for a while, it may be worth performing a hard reset on both, then set the DHCP on both.




i've been trying to use openreach modem which I bought from ebay few days ago

Edited by: "xPabloz" 21st Jun 2017
xPabloz

i've been trying to use openreach modem which I bought from ebay few days … i've been trying to use openreach modem which I bought from ebay few days ago


You've added more detail to your question but now not clear what you are attempting to do by using a modem primarily designed for fibre bb. Suggest you first try the combination of Sky device in modem mode (DHCP disabled) plus Asus with DHCP enabled, then when that combination is confirmed functional look at swapping-out the "modem-only" device.
I have a similar set up with my sky broadband, it all depends if you have the right openreach modem, it has to be a Huawei ecolife hg612 and follow this site to unlock the modem to work with adsl

kitz.co.uk/rou…htm

Once you unlock it you can use with both adsl and fibre, it's the best setup I've had. With broadband though you will have to set up the modem to work as a gateway, give it an ip and then in the asus router connect via that ip. If you need exact instructions I can try and help later when I'm on a PC as I use a rt-ac87u.
Edited by: "stoneblade" 21st Jun 2017
Sorry link to exact unlock

kitz.co.uk/rou…htm

Also I would recommend using Merlinwrt firmware on your Asus router, it has so many more security updates and regularly updated in comparison to Asus themselves.

asuswrt.lostrealm.ca just install as if you would a firmware update in Administration settings.
Edited by: "stoneblade" 21st Jun 2017
Original Poster
stoneblade

Sorry link to exact unlockhttp://www.kitz.co.uk/routers/hg612hacking.htm



Yeah thats the one I purchased. Will unlock it now. Also do you have have the link to the step by step guide to make it work with ADSL/Standard Broadband? Thanks

And yes I have already installed Merlinwrt on it
Edited by: "xPabloz" 21st Jun 2017
xPabloz

Yeah thats the one I purchased. Will unlock it now. Also do you have have … Yeah thats the one I purchased. Will unlock it now. Also do you have have the link to the step by step guide to make it work with ADSL/Standard Broadband? ThanksAnd yes I have already installed Merlinwrt on it



​Have you extracted your username and password from your sky modem yet? You will need it once you have hacked your btopenreach modem. Once you done that I can export my modem settings (without my username and password) which you can just import to yours and then change your broadband username and password, it too a few try to get the right set up for me and would be easier.
Original Poster
stoneblade

Have you extracted your username and password from your sky modem yet? … Have you extracted your username and password from your sky modem yet? You will need it once you have hacked your btopenreach modem. Once you done that I can export my modem settings (without my username and password) which you can just import to yours and then change your broadband username and password, it too a few try to get the right set up for me and would be easier.



Yes I have extracted the username and password. I also tried using generator and it gives me same username but different password. Anyway going back to unlocking the modem, I cant seem to find the download link of the firmware i will need to upload on to it.

And thanks for helping out

Edit: found it here : kitz.co.uk/rou…htm

would you suggest downloading "unlocked" version or "webgui" (also unlocked)

Edited by: "xPabloz" 21st Jun 2017
Weird for some reason my link to the firmware was removed, the GUI version the others you have to telnet through and it gets complicated.

Once you have unlocked the modem, login and then restore the settings under maintenance >> Device >> Configuration File >> Choose file and upload the one I sent. You then go to Basic >> WAN >> and change your username and password to your extracted.

Once done, save and it should connect, the ip address of the modem will now be 192.168.0.1 username: admin and password: password which is deafult and best to change through Maintenance >> Account on modem.

Check through Status >> WAN and will say connected and give you details and your line speed.


Edited by: "stoneblade" 21st Jun 2017
***Make sure your ASUS routers IP is different to the Openreach Modem, I use 192.168.1.1 Can change under LAN****

Connect the lan cable from LAN2 on the modem, to your WAN port on the router.

In your ASUS router, go to WAN >> WAN Connection type = Static IP

Enable WAN, NAT and UPnP.

IP Address = 192.168.0.2
SUBNET = 255.255.255.0
Default Gateway = 192.168.0.1
DNS = 90.207.238.97 (Sky ones, can be seen under WAN on the modem)
DNS 2 = 90.207.238.99


Edited by: "stoneblade" 21st Jun 2017
Original Poster
Finally its working. Thank you sooo much.
No problem, glad you got there in the end. Now the modem is unlocked and you ever upgrade to fibre, you can just change the settings and still use the same set up.
Original Poster
if you don't mind answering, what is actually going on with this setup as compared to most (if not all) of the guides online which focus on just fibre
Edited by: "xPabloz" 21st Jun 2017
Im not an expect on this but I think there are 2 ways you can use this modem to connect to the ISP, through PPoA (Point-to-Point Protocol over ATM) or PPoE (Point-to-Point Protocol over Ethernet). PPoE can be used directly from the router so you enter all your details like ISP username and password, and the router will control the modem or a bridge, PPoE is a pain to use as a set up with broadband and some providers dont allow it, like sky, i tried for hours trying to get it to work. Now PPoA allows the modem to control the connection itself, and is pretty much the standard for most ISP who provide their own routers (modem built in), this also is a better option as if you ever need to reboot your Asus router you wont drop connection and mess with skys stupid line optimisation, you reconnect to many times and it will think you have a bad line. Went for a month down from 21mb to 10! Hope that helps.
Original Poster
stoneblade

you reconnect to many times and it will think you have a bad line. Went … you reconnect to many times and it will think you have a bad line. Went for a month down from 21mb to 10! Hope that helps.



currently going through that phase for like atleast 2-3weeks now. connection drops few times a day on a good day. bad day like today will disconnect EVERY few minutes. Hoping to get sky engineer or something to fix that crap
I dont know how savvy you are with internet things, but have you tried changing your ADSL filter? I had enough of them going down, so bought a ADSL plate that replaced the socket, haven't had drop outs since. How long have you been with Sky? There is a set period of SLA for 10 to 30 days I think it is, that checks what the top rate your line can hold and in this time it might disconnect as its "topped off" the max and stabilizes. Also check in the modem page, your line stats, which is under Basic >>WAN I think, at work atm. If you check in there and check your line attenuation, this will give you an idea on how far you are form the exchange, and if you have a noisy line, also check errors on that page, if its high again might be line noise.
Original Poster
stoneblade

I dont know how savvy you are with internet things, but have you tried … I dont know how savvy you are with internet things, but have you tried changing your ADSL filter? I had enough of them going down, so bought a ADSL plate that replaced the socket, haven't had drop outs since. How long have you been with Sky? There is a set period of SLA for 10 to 30 days I think it is, that checks what the top rate your line can hold and in this time it might disconnect as its "topped off" the max and stabilizes. Also check in the modem page, your line stats, which is under Basic >>WAN I think, at work atm. If you check in there and check your line attenuation, this will give you an idea on how far you are form the exchange, and if you have a noisy line, also check errors on that page, if its high again might be line noise.



replaced the filter today which didnt really do much. since this issue started i just have to wait for set period (varies) before things go back to normal. during that period the connection will drop as many times it wants. Been with sky for years. Now that I can read all stats, i noticed Line rate changes drops from 18Mb to about 11Mb (actual speed 8mb and 13Mb respectively) when connection starts dropping.

these are my current stats.

https://i.pstorage.space/i/3OeXVgO21/original_Screen_Shot_2017-06-21_at_21.07.00.jpg

Edited by: "xPabloz" 21st Jun 2017
Your SNR seems pretty high, mine is 11db do you have an extension running from your main box? Or your running an extension line on your modem cable? I used too have a 10m cable from the main box to the modem and it played my connection up, so put the bt modem next to the main box and then used a longer lan cable instead and fixed my issues. If no extensions then might be line issue and only sky will be able to do anything.

One other thing to do is phone sky and ask to speak to second level support and ask them to re-enable sla (line stabilisation) on your line as the higher snr could be due to disconnects you've had with old modem disconnects and filter. Once re-enabled give it a few days and see if it starts lowering the snr.
Original Poster
stoneblade

Your SNR seems pretty high, mine is 11db do you have an extension running … Your SNR seems pretty high, mine is 11db do you have an extension running from your main box? Or your running an extension line on your modem cable? I used too have a 10m cable from the main box to the modem and it played my connection up, so put the bt modem next to the main box and then used a longer lan cable instead and fixed my issues. If no extensions then might be line issue and only sky will be able to do anything. One other thing to do is phone sky and ask to speak to second level support and ask them to re-enable sla (line stabilisation) on your line as the higher snr could be due to disconnects you've had with old modem disconnects and filter. Once re-enabled give it a few days and see if it starts lowering the snr.




Yeah I think the issue is with the line itself because with my current setup, the modem is directly connected to the main socket using the original short cable provided by sky and its still has the same issue even after changing filter. Also should I be concerned about the crc/fec/hec errors?

apparently there is a script to change snr. not sure if i want to mess around with it. forum.kitz.co.uk/ind…6.0



Edited by: "xPabloz" 22nd Jun 2017
I would be worried if your download was causing all the errors, upload is normal. My line stats show similar. Dont mess with the SNR on the modem, it can mess things up even more, especially with a bad line. You can squeeze a little more out of the line with fiddling, but you sacrifice stability on the line, and isn't worth the extra few bytes of download. I find the modem does a pretty good job of getting the most out of the line, where ISP modems tend to lower speeds for the stability.

As you can see on line stats, I have worse errors than you, so nothing to worry about and I have a stable line.

http://i.imgur.com/COTDwax.jpg
Edited by: "stoneblade" 22nd Jun 2017
Original Poster
Been trying to contact them since 8:30am. They are just messing around. after like 2hours managed to get through and tell my problem, was told to contact back in 10mins to get results of the tests they will carry out. rang them only to go through the same ****. apparently they will now ring me instead at 6pm to see if there is anything wrong with the line.
Ive never had any issue with Sky when ringing them, must be a busy time or something? You have any update with the line test?

Check here too

servicestatus.sky.com/
Original Poster
stoneblade

Ive never had any issue with Sky when ringing them, must be a busy time … Ive never had any issue with Sky when ringing them, must be a busy time or something? You have any update with the line test?Check here too https://servicestatus.sky.com/#/uk/d



managed to speak to someone who actually has some knowledge about this and he said the line was not stable. he changed my profile to make it more stable. however it looks like my speed has decreased with the new profile. line attenuation has increased from 18.5 to 27 too. my ping has also increased from 18ms to 33/34ms.

https://i.pstorage.space/i/v5jbvvlmw/original_Screen_Shot_2017-06-22_at_21.42.33.jpg

just noticed my traffic type changed too. not sure if that is a good thing or not

update 1: errors constantly increasing, line rate same but actual speeds am getting is slow AF. switching between 4/6mb - 10/11mb

https://i.pstorage.space/i/pYj6JRNo5/original_Screen_Shot_2017-06-22_at_22.48.17.jpg

update 2: errors still increasing but speed seems better at time of writing. i guess will need to test for a bit before i ring them back

https://i.pstorage.space/i/a6XR2XjNd/original_Screen_Shot_2017-06-22_at_23.57.53.jpg

Edited by: "xPabloz" 23rd Jun 2017
stoneblade21st Jun

Weird for some reason my link to the firmware was removed, the GUI version …Weird for some reason my link to the firmware was removed, the GUI version the others you have to telnet through and it gets complicated.Once you have unlocked the modem, login and then restore the settings under maintenance >> Device >> Configuration File >> Choose file and upload the one I sent. You then go to Basic >> WAN >> and change your username and password to your extracted.Once done, save and it should connect, the ip address of the modem will now be 192.168.0.1 username: admin and password: password which is deafult and best to change through Maintenance >> Account on modem.Check through Status >> WAN and will say connected and give you details and your line speed.



Hi i am in the process of doing this , how can i get your modem settings so i can import them into mine, thank you
Original Poster
ken563617th Aug

Hi i am in the process of doing this , how can i get your modem settings …Hi i am in the process of doing this , how can i get your modem settings so i can import them into mine, thank you


i just uploaded it on here. volafile.org/r/d…408


it will get deleted after 2 days
xPabloz1 h, 4 m ago

i just uploaded it on here. https://volafile.org/r/dcqwe408 it will get …i just uploaded it on here. https://volafile.org/r/dcqwe408 it will get deleted after 2 days


hi, thank you very much
Post a comment
Avatar
@
    Text

    Top Discussions

    Top Merchants