SYMBOLS the wrong way round on the keyboard

Hi Folks!

I need some help. Just bought father in law an Acer One keyboard. It has a Linux operating system, not Windows.

Two of the keys produce the wrong symbols when I type.

Looking at the keyboard, above the number 2 is the inverted comma sign (ie speech marks). Above the ' button (just above the SHIFT bar on the right hand side of the keyboard) is supposed to be the @ sign.

HOWEVER, when you use the shift button to type these symbols, the keys type the opposite, ie. if I want to type inverted commas, I have to use SHIFT and the ' button. If I want to type the @ symbol, I have to use SHIFT and the number 2 button.

This is OK for me, but my elderly father in law is a computer virgin and it will confuse him no end! Can you PLEASE help!!!!

Thanks in advance!

Sally

10 Comments

It is set as American. You need to change it to UK. I don't know about Linux, but you ought to have something to do with regional settings on it.

Its because its setup for american keyboard settings, u will need to go to control panel & change it to uk settings (although i dont where that would be on linux, someone else will tell u though)

sorry not much help how to fix it but thats why its doing it

cheers

Here you go:

1. Press Alt + F22. In the dialog type "sudo xterm" and hit the enter - … 1. Press Alt + F22. In the dialog type "sudo xterm" and hit the enter - linux terminal will appear3. type "vim /etc/sysconfig/i18n" and hit the enter - the file will be opened in the VI editor4. Change two variables (LANG and LANGUAGE) to reflect your needs. Use the code from the SUPPORTED attribute below, ie. for English type en_FR.UTF-8. For those who dont know how to work with VI here are few tips: Press "i" for editing the content, press "Escape" for leaving the edit mode, type ":wq" for save the content and quit the editor, if you want to quit without changing the file type ":w!".5. Reboot the computer - either from terminal by typing "reboot" or from taskbar throught the icon on the bottom right.

Click system, preferences, keyboard, layout on ubuntu

Original Poster

Hi Dmmccabe - wow thanks, still having a wee prob though!

I managed to get as far as the VI Editor showing the LANG and LANGUAGE parts. I'm not sure how to actually change it though. I can delete the text that's there already in these two sections, but don't seem to be able to actually type anything new in. Any ideas?

Sally

Original Poster

Ignore that - managed to edit it, reboot it, but still have the same probs for some bizarre reason @ " still have to be typed using the wrong keys!

Any more suggestions

Really appreciate all the help I've been given so far! Thanks folks!

Ah slight error I changed a value from the quote to what I thought should make it english layout, however I got it wrong.

Try this:

en_EN.UTF-8 instead of: en_FR.UTF-8

Original Poster

dmccabe;3795085

Ah slight error I changed a value from the quote to what I thought should … Ah slight error I changed a value from the quote to what I thought should make it english layout, however I got it wrong.Try this:en_EN.UTF-8 instead of: en_FR.UTF-8


Thanks dmccabe - will give that a try in the morning!! You're a star!

Original Poster

sb123;3804920

Thanks dmccabe - will give that a try in the morning!! You're a star!



LOL - Couldn't wait until morning! Managed to change it to en_EN etc, saved it then rebooted, but the bloody thing is still typing the keys the wrong way round!

Sorry to be such a pest, but do you have any more suggestions?

Sally
:thinking:
Post a comment
Avatar
@
    Text
    Top Discussions
    1. What do you feel like whinging about today?1917246
    2. Meerkat Movies (2 for 1 Cinema Codes) | Official Trading Thread414514052
    3. Just heard this...2 ★★★★★★★★★★★★★★ congrats to all on 392k ★★★★★★★★★★★★★★7763823
    4. miikeyblue and shabbird's (but mostly shabbird's) Tuesday night pub quiz!523387

    See more discussions