technika tv with red screen and red blur on picture

11
Found 17th Mar 2016
Hey everyone

Got a issue if someone can suggest a solution. Parents got a 42 '' technika Lcd tv which has developed a issue.

When they switch tv on, the screen is red after which the picture comes on. But there is a red blur covering the picture, like a shadow.

Anyone know what the problem might be and what's a solution? Don't mind getting it fixed if it's not too costly.

Thanks.
Community Updates
11 Comments
Don't know if it's something they have pressed. I've been through the picture options on the menu and changed a few things but nothings made a difference.
Try unplugging the tv and everything else connected to it, leave it unplugged and press the power button repeatedly a few times, reconnect everything and see if it's any better. It cycles the power out and can randomly fix a lot of issues! Might not work but worth a bash!
momartin

Try unplugging the tv and everything else connected to it, leave it … Try unplugging the tv and everything else connected to it, leave it unplugged and press the power button repeatedly a few times, reconnect everything and see if it's any better. It cycles the power out and can randomly fix a lot of issues! Might not work but worth a bash!


No worries. A bit unconventional but will try that tonight X)
EN1GMA

No worries. A bit unconventional but will try that tonight X)



Totally! But I've used it on laptops, phones, TVs, all sorts of electronics and it's fixed odd problems! Hope you get it sorted.
momartin

Try unplugging the tv and everything else connected to it, leave it … Try unplugging the tv and everything else connected to it, leave it unplugged and press the power button repeatedly a few times, reconnect everything and see if it's any better. It cycles the power out and can randomly fix a lot of issues! Might not work but worth a bash!



Hey M, is it the power button on the remote or the tv im supposed to repeatedly press?
EN1GMA

Hey M, is it the power button on the remote or the tv im supposed to … Hey M, is it the power button on the remote or the tv im supposed to repeatedly press?




The tv button
unplug it, carry it with help to the back yard and place it in the bin, then go currys and buy a new one. good luck
Have you downloaded a test chart and put it on the TV ? I would drop the red colour bias to see if that helped.
kester76

Have you downloaded a test chart and put it on the TV ? I would drop the … Have you downloaded a test chart and put it on the TV ? I would drop the red colour bias to see if that helped.


hi mate. I seriously have no idea what you are advising me to do X)

it was fine until a few days ago, picture was clear.
EN1GMA

hi mate. I seriously have no idea what you are advising me to do X)it was … hi mate. I seriously have no idea what you are advising me to do X)it was fine until a few days ago, picture was clear.



​You can change how much Red Blue and Green there is on the picture. Might be worth turning the red down a bit to see if it helps.
Oh yeah. Try a VGA connection on it and see if this has the same issue
Post a comment
Avatar
@
    Text

    Top Discussions

    Top Merchants