Groups

    TP-Link Archer C2 AC750 - Problems with wifi

    I bought one of the above routers when they were listed on here a while back.

    It has been completely flawless operating continuously without a glitch.

    That is until a few days ago. I came back from work and it was connecting on my laptop but had the little yellow ! over the wifi icon and it said limited access. Websites weren't loading so I switched the router off and back on again. It worked perfectly all evening.

    I then came back the next night to the same issue but switching off and on again made no difference.

    I have tried everything I can think of. I have swapped the network cable for a different one, I have factory reset the router and used the original wifi key. It can see the wifi network but when I go to connect to it it asks for the key then just says Windows can't connect to this network.

    This is the same with 2 laptops, 2 android phones, a tablet, an ipad etc.

    On the android phones it looks like it is going to connect but the wifi icon just increases to the top then empties then starts again, it does this for a few minutes then gives up without an error.

    Is it dead? Any suggestions?

    3 Comments

    It sounds like you've concluded that the router is broken only because there's no internet over wi-fi.

    That's three different systems there. Your internet connection, the router and the wi-fi. You need to narrow it down.

    Can you connect to the router's control panel (typically http://192.168.1.1 or similar)? That would suggest that the router is working fine and the issue is with your internet connection or modem.

    If you can't connect to it via wi-fi what about if you connect one of the laptops to the router with an ethernet cable and try it again?

    Sounds like your internet is down. If WIFI was down you wouldn't be able to connect at all with your laptop. Check your modem lights.

    Original Poster

    Thanks for the replies - spot on.

    The superhub is quite inaccessible as it is built in behind the unit but I could see lights on it and had tried resetting it with no luck.

    I took the unit apart to get to it and found the lights on it looked dim and were flickering rather than flashing.

    I found a spare 12v supply and tried that on it and the lights lit up properly so it looks like the power supply for the Superhub has failed.

    Annoyingly though as I had reset the TP Link which I use as an access point, I've had to reconfigure everything in there but it all seems to be working now.

    Will ask Virgin for a replacement
    Post a comment
    Avatar
    @
      Text
      Top Discussions
      1. Win a luxury five-star break for two in Paris with Le Bristol Paris and Eur…67
      2. Win a Davosa Ternos Submariner Wristwatch worth £64545
      3. Win a flagship smartphone - the HTC U1134
      4. Magazine competitions - Issue 39 @ tvchoicemagazine.co.uk66

      See more discussions