Groups

    Trying to connect Xbox 360 to internet through my PC

    I know networking questions pop up quite a bit it seems but I can't find a solution to this anywhere, tried looking for everything on google.

    Basically, my PC is connected to the internet via wireless through a BT home hub router. I have an Ethernet cable so plugged that in to my 360 and the other end in to the PC. Then I right clicked on the "LAN" connection and enabled sharing through this, but as soon as I do that my wireless connection to the internet is dropped - if I disable sharing then my PC connects to the internet again.

    I have a feeling it has something to do with assigning IP's? I'm using vista if that makes a difference.

    Thanks in advance for any help

    8 Comments

    your bt home hub should have spare ethernet ports, i used to connect my 360 through ethernet on home hub with no problems.

    If your not near the home hub, check your connection settings, and allow your wireless connection to be shared.

    Original Poster

    Yeah unfortinatly I'm no where near the hub, having to connect through my PC is a compromise.

    I actually didn't try that, though that allowing my wireless connection to be shared just meant connecting my PC to the internet via a cable for example and allowing other PC's with wireless adaptors to tap in to that through my PC, but will give it a try thanks .

    The best way I've found to do it is to go to control panel\ network and sharing center\ manage network connections, then select both your wireless connection and the wired connection to your xbox, right click and select 'bridge connections'.

    This should get your xbox connected and will allow you to have an open NAT connection (necessary for full connectivity for some multiplayer games like Halo 3)

    Hope that helps!

    I used to have the same set up ,just with xp instead of vista.
    Right click on wireless network connection>status>support>details.
    Write down your DNS server number
    Go to network connections>click on the xbox connection (Local Area Connection)>click on Properties>click on internet protocol (TCP/IP) then click properties.
    Enter info
    IP: 192.168.0.99
    Subnet Mask: 255.255.255.0
    Default Gateway -Blank
    Preffered DNS Server - Enter the number you made a note of


    Go on your xbox ,System>network settings >edit settings>IP Settings>manual

    Then enter
    IP:192.168.0.100
    Subnet Mask-255.255.255.0
    Gateway- 192.168.0.99
    Press done>go back to edit settings>go on set DNS settings.
    Set both primary and secondary DNS as 192.168.0.99

    on the PC go>control panel>Network >right click on the the wireless network connection>click properties>click advance>check the box saying"allow other users to connect to the internet through this computer.

    That should work.
    If the DNS server fails ont he xbox set it to automatic



    Hopfully this should help you,as i've typed all thisout

    Original Poster

    Excellent, thanks for all the replies! that seems to have done the trick.

    Rep added :-)

    JimmyW;1433055

    Excellent, thanks for all the replies! that seems to have done the … Excellent, thanks for all the replies! that seems to have done the trick.Rep added :-)



    Good to hear

    Here is some extra functionality you may be able to make use of from one of my posts:

    ]Here

    how do i connect my 360 to live all i have is a pc upstairs with wirless connecting to the router downstairs and an ethernet cable. can i use the ethernet cable to get on live through my pc and its wireless connector. i already have an xbox live but not an account. how do i do this please. can u put it in steps any normal person could understand please. also i only have windows xp
    Post a comment
    Avatar
    @
      Text
      Top Discussions
      1. Hatchimals on Ebay - are they fake?11
      2. Ditched Sky1113
      3. Tough Doggy Ball Recommendations, Please?914
      4. Unexpected house guest query (Ratatouille)56

      See more discussions