Turtle Beach gaming headphoned - no game sound

11
Found 28th Jun 2012
Lost my gaming sound via the headset .. But can still hear voice chat .. On xbox ..

Anyone else had this problem and how do you fix it ?

All wires and cables are plugged in so has to be a settings issue.

Help is appreciated cheers.
Community Updates
11 Comments
"All wires and cables are plugged in so has to be a settings issue. "

Not necessarily, could be a knackered wire. Try it on another Xbox if possible or a PC.
has it got 2 knobs you change one being game chat the other being game sound. HTH.
Original Poster
Px21's
Original Poster
Legend101

"All wires and cables are plugged in so has to be a settings issue. "Not … "All wires and cables are plugged in so has to be a settings issue. "Not necessarily, could be a knackered wire. Try it on another Xbox if possible or a PC.



See i think it is a settings issue because i can hear the voice chat perfectly well ..
On play station you have to go to setting and put spun to come through these. It usually has the chat coming through as standard.
kev_u8701r

Px21's



I've broken 2 of those
Original Poster
kylewalker

http://www.avforums.com/forums/ps3-hardware/1350338-turle-beach-px21-headhphones-no-game-sound.htmlhttp://answers.yahoo.com/question/index?qid=20120216162109AAwonXrHTH. btw google is your friend.

need info on xbox if possible .
Doesnt the px21 have the red white cable then a USB also? The in game sounds will be carried over the red and white and voice chat over the USB cable, which supports the idea of a knackered wire and why you are still able to hear the voice chat.
Original Poster
Peterdj41

Doesnt the px21 have the red white cable then a USB also? The in game … Doesnt the px21 have the red white cable then a USB also? The in game sounds will be carried over the red and white and voice chat over the USB cable, which supports the idea of a knackered wire and why you are still able to hear the voice chat.



Reason is its the USB that carries the power to the amp .. the x1's work with sounds via red and white .. voice only and no in game sounds ..but i cannot for the life of me figure out how to put it back on the in game sound settings any that correct the issue anyway lol
I've got PX3 Turtle Beach headset, I brought it today brand new, I connected it up perfectly & when I connected them I turned on the transmitter and the headset and paired them, as soon as they paired I got white noise through the headset, iv been looking on the Internet for a solution for 5 hours and not one thing has come up yet but alot of people have the same problem,can someone please help me if they know what's wron, 100% it is not my playstation 3 because that's also brand new, i would appreciate it if someone could help, thank you
Post a comment
Avatar
@
    Text

    Top Discussions