Unfortunately, this discussion is no longer valid

Using a "Leapfrog LeapPad Explorer" on a Mac - trouble shooting

Posted 5th Dec 2011
Have you recently purchased a 'Leapfrog LeapPad Explorer' for your little one, for Christmas this year? Thought locating it was the biggest problem...unfortunately for some this is just the start of the problem. Your next one is going to be downloading those free Apps and registering the LeapPad through a downloadable application called 'Connect'

First of all, open it BEFORE Christmas and set it up as it is not a 5 minute job (if it doesn't work ie "Connect is unable to communicate with the LeapPad", it may take several hours!) and once your little one has it in their sticky paws, they want it to work NOW!

I would suggest you go to the Leapfrog site and download Connect from the site, don't use the discs. From both mine and others experience, you end up removing the software installation and downloading from the site anyway!

Next, if you have any antivirus software installed and Firewall, you need to disable them whilst you register the LeapPad and download the free Apps - don't forget to enable them when you have finished. Even with a Mac, you need to turn the Firewall off to do this as the settings on your Mac will prevent the LeapPad connection.

If you are using a Mac, even turning off the Firewall, this may not be enough to enable Connect to run as you may still need to manually set up your IP Address. So this is how you can do this, it's easy when you know how :o)....:

You will need to manually set up your ip address by following the steps below:

To set a static IP address on a Mac, please follow the instruction below:

1. Turn on the LeapPad and connect it to the computer

2. Open System Preferences by clicking on the icon in the dock.

3. Go to the "Network" control panel under the "Internet & Network" category.

4. Select your ethernet connection (LeapFrog) from the list of available connections on the left side of the control panel window. Then click "Advanced" in the lower-right corner of the window.

5. Click on the "TCP/IP" tab at the top of the control panel window.

6. Choose "Manually" from the drop-down list at the top of the window.

7. Enter the static IP address, subnet mask, and Router numbers as follows:

IP Address:
Subnet Mask:

8. Click "OK" to save your settings and connect through the static IP address.

I have added this on this forum as I bought my LeapPad back in August, following the Tesco's offer and know loads more of you guys did. I thought I'd share this as it might save you the hours and hours of swearing, troubleshoot Googling, swearing and several glasses of wine whilst you feel this urge to pick it up and chuck it hard against the wall!

Have fun and if you do have any problems, PM me and I will try and help as I tried setting my LeapPad up on both a Mac and a normal PC and both drove me mad but I found several fixes along the way and at last, it's all done :o)
Community Updates


thanks this will save time on xmas day
Many thanks. Saved me much time. :-)
i want to set up the leappad for my grandson before christmas. but i have a pc and my daughter who will mostly be dealing with apps etc has a mac. my question is this. can i set it up on my pc and will my daughter still be able to connect on her mac. thanks for any help you can provide. happy holidays.


i want to set up the leappad for my grandson before christmas. but i … i want to set up the leappad for my grandson before christmas. but i have a pc and my daughter who will mostly be dealing with apps etc has a mac. my question is this. can i set it up on my pc and will my daughter still be able to connect on her mac. thanks for any help you can provide. happy holidays.pam

When you download 'Connect' either from the disc supplied or the software of Leapfrog's website, all that is doing is allowing you to register the LeapPad and download the free apps. The software asks whether it is for a Mac or PC. It may be that you both want to have the software on your systems as you can buy further 'apps' from Leapfrog and then both you and your daughter can buy them off the site. As I have used both PC and Mac to set up the LeapPad, both are now interchangeable.

The only thing you need to do when registering the LeapPad is to tell your daughter the details of the account name and password you set up on the Leapfrog site. That way, once your grandson has the LeapPad at his home, it can be connected (via Connect software) to your daughter's Mac. (She may need to follow the instructions I listed on this ^above^ to manually set up her IP Address - or if she has a newer Mac, it may work OK by just turning off the Firewall (turn it back on when finished

Just a tip with the PC, make sure any antivirus is turned off as well as the Firewall. I work in IT and it goes completely against the grain but this was what interfered with the PC's ability and other people seem to have had the same problem. (Again, just make sure it's all turned back on again when you finish)

I hope this helps but please let me know if you have any problems.

Have a wonderful Christmas and fabulous 2012.



I've tried doing everything you suggested here but it still doesn't connect. Any other suggestions/tips?

I've done the above, but I think my issues (Mac osx10) maybe deeper. The application won't even start up. It simply throws up the logo then says Starting up... but just hangs. Any thoughts or help greatly appreciated
Hi there,

The only other thing, without seeing what your system is actually doing is to check your screen resolution - it needs to be the same configuration that Leapfrog box states.

Both the Firewall and Antivirus need to be turned off.

You can email Leapfrog for bespoke technical queries: at leapfrogaccounts@em.leapfrog.com, they can send you an application which will copy the Leapfrog programme files and .ZIP them so that you can send them for technical analysis. It takes a couple of days but they will then tell you, step by step, what you need to do and then you wont have any further issues with it.

Hope that helps and Happy Christmas.
My 10 year old daughter done it for me in 10 mins x
What settings would I need for an additional device?
I'm sorry but it will not connect with my Mac :0(
I have done EVERYTHING to try and set this leappad up for my daughter (who is not impressed that she couldnt play with it on her birthday) Ive turned my firewall off i hit connect and it gets stuck with 1 percent left to run??????? Help, i have emailed leappad who are very slow at responding! It is very frustrating as normally i am a wizz at solving these kinds of things!
I'm in the same boat as jamestrusler.... can't get the LeapFrog Connect to start up. Just sits on "Starting up...." forever. I have Mac OS 10.7.4, did the IP address thing, no Firewall or Anti-virus running, updated Flash. How could it possibly be these difficult!!! Anyone get it to work with the Starting up problem???
Hi, I'm having this problem now ! I had already installed it all and it worked perfectly on my pc through windows. However we no longer have that computer, and have recently bought a MAC. Ive downloaded the "connect" but when i connect my leap pad explorer to the mac pro it is saying it cannot find it and to switch off and try again!!! I have done this about 20 times in many different ways and nothing is working! You say i need to disable the firewall? how do i do this? and what else do i need to do?
I look forward to hearing from you !
A very stressed mum of an impatient 3 year old ! :-)
I have the same problem. It used to work for me, but ever since I installed the latest mandatory upgrade to LeapFrog Connect it no longer works with my Explorers. It still works with the Leapster 2. Looks like many of us are having the same problem.
Great advice, thanks. One question: how on earth did you figure it out?
Damn. As with NoeValleyJim, the latest update has broken it.
Thank you SO much for posting this!! I have no idea how you figured it out but I am quite certain I would never have gotten this to work otherwise. I'm a Mac user and I tried installing it three or four times but the program kept grinding to a halt. I followed the steps for entering the IP address and it worked like a charm. You are AWESOME! My son and I both thank you!!
No dice. Using 10.7.4 and leappad 1. Every time I plug it into the USB port, it changes the IP, subnet mask and router addresses to different ones.... I had this leappad connected to a PC, but now only have my Mac. Any other ideas? Thanks in advance for your help.

Sorry, commenting is no longer available on this discussion.